Last Comment Bug 765947 - Preprocess the config file for generated events
: Preprocess the config file for generated events
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on: 765163
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 16:02 PDT by Olli Pettay [:smaug]
Modified: 2012-07-20 14:07 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.07 KB, patch)
2012-06-19 07:33 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Review
patch (6.99 KB, patch)
2012-06-19 08:19 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Review
patch (7.44 KB, patch)
2012-06-19 08:45 PDT, Olli Pettay [:smaug]
khuey: review+
Details | Diff | Review
patch (7.41 KB, patch)
2012-07-20 10:38 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Review

Description Olli Pettay [:smaug] 2012-06-18 16:02:04 PDT
B2G has some events which aren't in FF builds. We should be able to preprocess the
conf file so that we can still autogenerate the code for b2g.
Comment 1 Olli Pettay [:smaug] 2012-06-19 07:33:03 PDT
Created attachment 634415 [details] [diff] [review]
patch
Comment 2 Olli Pettay [:smaug] 2012-06-19 07:35:04 PDT
https://tbpl.mozilla.org/?tree=Try&rev=77b3b3a3e91e
Comment 3 Olli Pettay [:smaug] 2012-06-19 07:50:55 PDT
Comment on attachment 634415 [details] [diff] [review]
patch

Hmm, this wasn't too successful on try
Comment 4 Olli Pettay [:smaug] 2012-06-19 08:19:29 PDT
Created attachment 634427 [details] [diff] [review]
patch

Force some dependencies
Comment 5 Olli Pettay [:smaug] 2012-06-19 08:19:52 PDT
https://tbpl.mozilla.org/?tree=Try&rev=56b476f67823
Comment 6 Olli Pettay [:smaug] 2012-06-19 08:21:35 PDT
Comment on attachment 634427 [details] [diff] [review]
patch

Argh, still no luck
Comment 7 Olli Pettay [:smaug] 2012-06-19 08:45:54 PDT
Created attachment 634446 [details] [diff] [review]
patch

This one should work

https://tbpl.mozilla.org/?tree=Try&rev=27f45e15bb5c
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2012-07-20 07:23:04 PDT
Comment on attachment 634446 [details] [diff] [review]
patch

Review of attachment 634446 [details] [diff] [review]:
-----------------------------------------------------------------

Oh nice, you made the changes here I was going to ask for in the other bug.

::: js/xpconnect/src/Makefile.in
@@ +223,5 @@
>  	  -I $(DEPTH)/dist/idl \
>  	  --header-output GeneratedEvents.h \
> +	  event_impl_gen.conf
> +
> +exports:: GeneratedEvents.h

This shouldn't be necessary, since GeneratedEvents.h is in EXPORTS.
Comment 9 Olli Pettay [:smaug] 2012-07-20 10:38:46 PDT
Created attachment 644389 [details] [diff] [review]
patch
Comment 10 Olli Pettay [:smaug] 2012-07-20 14:07:23 PDT
https://hg.mozilla.org/mozilla-central/rev/b3f2fb31cd77

Note You need to log in before you can comment on or make changes to this bug.