Last Comment Bug 765952 - Out of memory crash in libdvm or hang after a while in this testcase with font-size: 900;
: Out of memory crash in libdvm or hang after a while in this testcase with fon...
Status: RESOLVED DUPLICATE of bug 766647
[native-crash]
: crash, hang, regression, testcase
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 16 Branch
: ARM Android
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 16:20 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-08-01 07:15 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
fixed
unaffected


Attachments
testcase (900 bytes, text/html)
2012-06-18 16:20 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2012-06-18 16:20:54 PDT
Created attachment 634226 [details]
testcase

See testcase, in current trunk build this is hanging Fennec or causing a crash within 30s or so.

https://crash-stats.mozilla.com/report/index/bp-114a2259-9e3c-4c3c-915c-5e46e2120618
0 	libdvm.so 	libdvm.so@0x5098e

It doesn't crash beta or Aurora, so it looks like a regression.
Comment 1 Adrian Tamas (:AdrianT) 2012-06-19 04:34:14 PDT
Good build: May 15th c1c12246f5ac
Bad build: May 15th 4e3362864fbd 

Possible regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c1c12246f5ac&tochange=4e3362864fbd

Tested on HTC Desire running Android 2.2. I am getting only hangs after a few seconds.
Comment 2 Scoobidiver (away) 2012-06-19 04:41:15 PDT
The regression range is in 15.0a1 while 15.0a2 is unaffected. It's odd.
Comment 3 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-06-19 05:20:30 PDT
Yeah, that seems strange.
Adrian, can you reproduce this in the latest Aurora build? Since I can't reproduce it there.
Comment 4 Adrian Tamas (:AdrianT) 2012-06-19 05:24:20 PDT
I am able to reproduce the issue on Aurora 15.0a2 2012-06-19 on the HTC Desire. In 10-15 seconds after loading the page Aurora becomes unresponsive for me. I haven't been able to reproduce a crash on any build I tried.
Comment 5 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-06-19 13:31:20 PDT
I tested some inbound builds; this was introduced with cset 7d21f92a5e05 from bug 755070.
Comment 6 Scoobidiver (away) 2012-06-19 23:45:21 PDT
Bug 755070 landed in 16.0a1, so the hang issue in Aurora is unrelated to the crash.
Comment 7 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-07-18 12:24:37 PDT
qawanted to see if this still happens in a build with bug 766647 (landed on inbound this morning).
Comment 8 Adrian Tamas (:AdrianT) 2012-07-23 00:25:49 PDT
On Nightly 17.0a1 2012-07-22 on HTC Desire Z running Android 2.3.3 loading the page no longer hangs Firefox Mobile.

On Aurora 16.0a2 2012-07-22 after loading the page within 10-15 seconds the app freezes and eventually a force close dialog is displayed.
Comment 9 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-07-30 12:21:57 PDT
This should be fixed on aurora 16 as well now that I've uplifted bug 766647 there.
Comment 10 away[Nov24,Dec5) Kartikaya Gupta (email:kats@mozilla.com) 2012-08-01 07:12:53 PDT
Confirmed that aurora doesn't have this anymore, so duping this bug.

*** This bug has been marked as a duplicate of bug 766647 ***

Note You need to log in before you can comment on or make changes to this bug.