Last Comment Bug 766011 - IonMonkey: Only monitor types in InvokeFunction when necessary
: IonMonkey: Only monitor types in InvokeFunction when necessary
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-06-18 19:44 PDT by David Anderson [:dvander]
Modified: 2012-06-21 14:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (2.06 KB, patch)
2012-06-18 19:44 PDT, David Anderson [:dvander]
bhackett1024: review+
Details | Diff | Splinter Review

Description David Anderson [:dvander] 2012-06-18 19:44:13 PDT
Created attachment 634274 [details] [diff] [review]
fix

This is small and we really shouldn't have to do this, but it shows up in the richards profile because we don't have polymorphic call inlining yet. It can't hurt.
Comment 1 Jan de Mooij [:jandem] 2012-06-19 10:34:27 PDT
Comment on attachment 634274 [details] [diff] [review]
fix

Flipping review to bhackett as discussed, I'm not entirely sure this always holds.
Comment 2 Brian Hackett (:bhackett) 2012-06-19 12:18:23 PDT
Comment on attachment 634274 [details] [diff] [review]
fix

Review of attachment 634274 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/ion/VMFunctions.cpp
@@ +68,5 @@
> +    // TI will return false for monitorReturnTypes, meaning there is no
> +    // TypeBarrier or Monitor instruction following this. However, we need to
> +    // explicitly monitor if the callee has not been analyzed yet. We special
> +    // case this to avoid the cost of ion::GetPcScript if we must take this
> +    // patch frequently.

s/patch/path
Comment 3 David Anderson [:dvander] 2012-06-21 14:58:17 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/572de56569fe

Note You need to log in before you can comment on or make changes to this bug.