Last Comment Bug 766017 - Fix some skia warnings
: Fix some skia warnings
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: David Zbarsky (:dzbarsky)
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 21:10 PDT by David Zbarsky (:dzbarsky)
Modified: 2012-06-23 05:45 PDT (History)
3 users (show)
dzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (29.12 KB, patch)
2012-06-18 21:10 PDT, David Zbarsky (:dzbarsky)
gwright: review+
Details | Diff | Splinter Review
Checked in patch (59.91 KB, patch)
2012-06-22 13:18 PDT, David Zbarsky (:dzbarsky)
no flags Details | Diff | Splinter Review

Description David Zbarsky (:dzbarsky) 2012-06-18 21:10:51 PDT
Created attachment 634288 [details] [diff] [review]
Patch

We may want to keep some of the functions since they're part of the API that we don't use, but some can probably be removed.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-06-18 22:08:58 PDT
Comment on attachment 634288 [details] [diff] [review]
Patch

These kinds of patches tend to cause needless pain when rebasing upstream projects. It's probably better to submit this directly upstream. George can help with that if needed.
Comment 2 George Wright (:gw280) (:gwright) 2012-06-22 09:27:15 PDT
This doesn't apply against upstream :(
Comment 3 George Wright (:gw280) (:gwright) 2012-06-22 13:03:23 PDT
Comment on attachment 634288 [details] [diff] [review]
Patch

Let's land this for now, and we can deal with rebasing later. Please make a diff and put it in the skia/patches directory when you land this.
Comment 4 David Zbarsky (:dzbarsky) 2012-06-22 13:17:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9cee44a83f21
Comment 5 David Zbarsky (:dzbarsky) 2012-06-22 13:18:31 PDT
Created attachment 635882 [details] [diff] [review]
Checked in patch
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-06-23 05:45:35 PDT
https://hg.mozilla.org/mozilla-central/rev/9cee44a83f21

Note You need to log in before you can comment on or make changes to this bug.