Closed Bug 766035 Opened 8 years ago Closed 4 years ago

PhotoSwipe.JS - Mobile Roadie PJs Coffee - Selecting to View Photos Never Finishes Loading on FF for Android

Categories

(Web Compatibility :: Mobile, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jsmith, Assigned: karlcow)

References

()

Details

(Whiteboard: [lib-photoswipe.js][clientsniff][sitewait][needsandroidversion])

Steps:

1. Go to http://mobileroadie.com/m/pjs-coffee
2. Select PJ's Coffee Pics

Expected:

A thumbnail listing of photos should show in an app-like format.

Actual:

The page continuously sits spinning the loading dial, but nothing ends up loading.

Additional Notes:

Issues does not reproduce on the stock browser or desktop firefox.
I can reproduce this changing my user-agent on desktop to mobile Firefox. I get a client-side error:

Uncaught TypeError: Cannot call method 'toString' of null

h.PhotoSwipeClass.d.initialize
l
a.createInstance
a.attach
e.jQuery.fn.photoSwipe
(anonymous function)
f.Callbacks.n jquery-1.7.1.min.js:2
f.Callbacks.o.add jquery-1.7.1.min.js:2
e.fn.e.ready jquery-1.7.1.min.js:2
(anonymous function)
(anonymous function)
e.extend.globalEval jquery-1.7.1.min.js:2
e.extend.globalEval jquery-1.7.1.min.js:2
bp jquery-1.7.1.min.js:2
e.extend.each jquery-1.7.1.min.js:2
f.fn.extend.domManip jquery-1.7.1.min.js:4
f.fn.extend.append jquery-1.7.1.min.js:3
f.each.f.fn.(anonymous function) jquery-1.7.1.min.js:4
a.mobile.loadPage.a.mobile.allowCrossDomainPages.l.isSameDomain.a.ajax.success jquery.mobile-1.1.0.min.js:58
f.Callbacks.n jquery-1.7.1.min.js:2
f.Callbacks.o.fireWith jquery-1.7.1.min.js:2
w jquery-1.7.1.min.js:4
f.support.ajax.f.ajaxTransport.send.d


PhotoSwipe.JS which is from http://www.codecomputerlove.com/

I'll send them an email.
Component: General → Evangelism
QA Contact: general → evangelism
Summary: Mobile Roadie PJs Coffee - Selecting to View Photos Never Finishes Loading on FF for Android, Works fine on Desktop Firefox and Stock Browser → PhotoSwipe.JS - Mobile Roadie PJs Coffee - Selecting to View Photos Never Finishes Loading on FF for Android
PhotoSwipe.JS library updated, Mobile Roadie needs to use the new library
Site URL changed to: http://m.zipscene.com/pjs-coffee/, and this works now.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
The issue is still reproducible at both http://m.zipscene.com/pjs-coffee/ and http://mobileroadie.com/m/pjs-coffee on Nightly 18.0a1 2012-08-28, Aurora 16.0a2 2012-08-27 and Firefox Mobile 15 RC using a Motorola Droid 3 running Android 2.3.4 and a Nexus Galaxy R running Android 2.3.4. Also the issue is still reproducible when changing the user agent on Desktop Firefox to the Android User Agent but is not reproducible if the link is loaded directly
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I can also reproduce the issue with Nightly 18.0a1 2012-08-28 on a Galaxy S2 with ICS 4.0.4.

STR:
1. Open http://m.zipscene.com/pjs-coffee/
2. Click on Photos
3. Click on the library that is listed (Simply the Best)

Expected results:
Photo library loads.

Actual results:
I see a spinner that just continues to spin.

Aaron - On what device did you verify the fix?
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Script is a bit careless when trying to extract the Android version. 

/zmp-m/js/code.photoswipe.jquery-2.1.6.min.js contains:

if(a.Browser.android&&e.navigator.userAgent.match(/Android (\d+.\d+)/).toString().replace(/^.*\,/,"")>=2.1)this.isBackEventSupported=!0;if(!this.isBackEventSupported)this.isBackEventSupported=a.objectHasProperty(e,"onhashchange");

The code throws because without any version number after "Android" in the UA, match() returns null.
Status: REOPENED → NEW
Whiteboard: [lib-photoswipe.js][clientsniff][contactready][needsandroidversion]
Trying to contact through twitter.
http://twitter.com/MozWebCompat/status/429137012059164672
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [lib-photoswipe.js][clientsniff][contactready][needsandroidversion] → [lib-photoswipe.js][clientsniff][sitewait][needsandroidversion]
It seems to be working on the Aurora 32 I have on the Android device.
I will close it as FIXED.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago6 years ago
Resolution: --- → FIXED
Still an issue (with the normal Fx Android UA string)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
http://m.zipscene.com/pjs-coffee/
Doesn't exist anymore.
Status: NEW → RESOLVED
Closed: 6 years ago4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.