bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

svg line is hard to interact with mouse pointer

RESOLVED DUPLICATE of bug 676001

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 676001
6 years ago
6 years ago

People

(Reporter: mountains, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 634316 [details]
linebugonfirefox.html

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

open the attachment with firefox(version 9,12,13 have been confirmed), two line are displayed. one is nearly horizontal. another is complete horizontal.
cursor="crosshair" have been set for the two line. so when mouse move over the line, the curson will be change to crosshair.




Actual results:

but acctually, the first line is very hard to response to mouse pointer on some location of the line. but the secode line is easy on every location of the line. 
so i think the line is wide enough. maybe firefox has some problem on the situation.
I have tested on IE9 and chrome, it works well.


Expected results:

the first line should be easy to responese to mouse pointer. that means curson should change to crosshair when the curson move over the line.

Updated

6 years ago
Attachment #634316 - Attachment mime type: text/plain → text/html

Updated

6 years ago
Component: Untriaged → SVG
Product: Firefox → Core
QA Contact: untriaged → general
(Reporter)

Comment 1

6 years ago
on firefox,only the line is nearly horizontal,the line is hard to interact with mouse pointer. but in other situation, it works well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676001
You need to log in before you can comment on or make changes to this bug.