Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 766065 - Assertion failure: iter.isNativeCall() && iter.callee()->native() == DumpStack, at shell/js.cpp:2141
: Assertion failure: iter.isNativeCall() && iter.callee()->native() == DumpStac...
[js:t] [jsbugmon:]
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: general
: Jason Orendorff [:jorendorff]
Depends on:
Blocks: langfuzz
  Show dependency treegraph
Reported: 2012-06-19 04:46 PDT by Christian Holler (:decoder)
Modified: 2013-01-19 14:27 PST (History)
4 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Christian Holler (:decoder) 2012-06-19 04:46:33 PDT
The following test asserts on mozilla-central revision 19bfe36cace8 (options -m -n -a):

function testApplyCallHelper(f) {
    for (var i = 0; i < 10; ++i) dumpStack.apply(this,[0,1]);
function testApplyCall() {
    var r = testApplyCallHelper(function (a0,a1,a2,a3,a4,a5,a6,a7) { x = [a0,a1,a2,a3,a4,a5,a6,a7]; });

Likely debug only due to "dumpStack" being involved.
Comment 1 Christian Holler (:decoder) 2012-08-01 19:11:10 PDT
JSBugMon: The testcase found in this bug no longer reproduces (tried revision 7fe96a690596).
Comment 2 Christian Holler (:decoder) 2012-08-21 06:17:31 PDT
JSBugMon: Fix Bisection requested, result:
autoBisect shows this is probably related to the following changeset:

The first good revision is:
changeset:   97988:b323d6090b21
user:        Luke Wagner
date:        Fri Jun 29 10:34:09 2012 -0700
summary:     Bug 768446 - Remove StackIter stack-sniffing (r=dvander)
Comment 3 Christian Holler (:decoder) 2012-08-21 06:19:44 PDT
Assuming this was fixed by bug 768446 which seems plausible.

*** This bug has been marked as a duplicate of bug 768446 ***
Comment 4 Gary Kwong [:gkw] [:nth10sd] 2012-08-21 06:33:33 PDT
if it's a known plausible fix, it's still marked resolved FIXED.
Comment 5 Christian Holler (:decoder) 2013-01-19 14:27:31 PST
Automatically extracted testcase for this bug was committed:

Note You need to log in before you can comment on or make changes to this bug.