If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PDF doesn't render with error message: "JPEG error: unknown JPEG marker ffc1"

RESOLVED FIXED in Firefox 25

Status

()

Firefox
PDF Viewer
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: ianbicking, Unassigned)

Tracking

15 Branch
Firefox 25
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox23 affected, firefox24 affected)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-jpeg][https://github.com/notmasteryet/jpgjs/issues/13][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3390)

(Reporter)

Description

5 years ago
This PDF only shows a blank page: http://www.minneapolismn.gov/www/groups/public/@clerk/documents/webcontent/wcms1p-094235.pdf

(But works fine with Mac Preview.)

Using Nightly 16.0a1 (2012-06-12)
[15:17:34.394] An error occurred while rendering the page.
PDF.JS Build: c2cfa99
Message: JPEG error: unknown JPEG marker ffc1
Stack: error@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:620
JpegStream_ensureBuffer@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:29003
DecodeStream_getBytes@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:28286
PDFImage_getImageBytes@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:24233
PDFImage_fillRgbaBuffer@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:24188
@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:13367
@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:23959
Promise_resolve@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:1113
@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:1060
Promise_resolve@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:1113
PDFImage_buildImage@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:23978
buildPaintImageXObject@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:13369
PartialEvaluator_getOperatorList@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:13474
Page_getOperatorList@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:191
wphSetupRenderPage@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:30695
messageHandlerComObjOnMessage@blob:8700af4f-29f5-cd48-bd42-df4854ac2f4b:30549
 @ resource://pdf.js/web/viewer.js:637
Whiteboard: [pdfjs-c-rendering][pdfjs-d-jpeg]

Updated

5 years ago
Summary: PDF doesn't render → PDF doesn't render with error message: "JPEG error: unknown JPEG marker ffc1"
Whiteboard: [pdfjs-c-rendering][pdfjs-d-jpeg] → [pdfjs-c-rendering][pdfjs-d-jpeg][https://github.com/notmasteryet/jpgjs/issues/13]

Updated

5 years ago
Duplicate of this bug: 836802

Comment 3

5 years ago
Download a PDF file below:
http://www.geocities.jp/todaijichikai/files/2012gb80seiseki.pdf

And when I load the pdf at http://mozilla.github.io/pdf.js/web/viewer.html,
it shows a similar error.

PDF.js v0.8.49 (build: 369b81b)
Message: JPEG error: unknown JPEG marker ffc1
Stack: error@http://mozilla.github.io/pdf.js/build/pdf.js:761
JpegStream_ensureBuffer@http://mozilla.github.io/pdf.js/build/pdf.js:32043
DecodeStream_getBytes@http://mozilla.github.io/pdf.js/build/pdf.js:31326
PDFImage_getImageBytes@http://mozilla.github.io/pdf.js/build/pdf.js:27201
PDFImage_fillRgbaBuffer@http://mozilla.github.io/pdf.js/build/pdf.js:27135
PDFImage_getImageData@http://mozilla.github.io/pdf.js/build/pdf.js:27196
pdfjsWrapper/PartialEvaluator_getOperatorList/buildPaintImageXObject/<@http://mozilla.github.io/pdf.js/build/pdf.js:14465
pdfjsWrapper/PDFImage_buildImage/<@http://mozilla.github.io/pdf.js/build/pdf.js:26879
Promise_resolve@http://mozilla.github.io/pdf.js/build/pdf.js:1361
pdfjsWrapper/Promise_all/<@http://mozilla.github.io/pdf.js/build/pdf.js:1308
Promise_resolve@http://mozilla.github.io/pdf.js/build/pdf.js:1361
PDFImage_buildImage@http://mozilla.github.io/pdf.js/build/pdf.js:26902
buildPaintImageXObject@http://mozilla.github.io/pdf.js/build/pdf.js:14467
PartialEvaluator_getOperatorList@http://mozilla.github.io/pdf.js/build/pdf.js:14587
Page_getOperatorList@http://mozilla.github.io/pdf.js/build/pdf.js:240
wphSetupRenderPage@http://mozilla.github.io/pdf.js/build/pdf.js:33785
messageHandlerComObjOnMessage@http://mozilla.github.io/pdf.js/build/pdf.js:33602

Updated

4 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-jpeg][https://github.com/notmasteryet/jpgjs/issues/13] → [pdfjs-c-rendering][pdfjs-d-jpeg][https://github.com/notmasteryet/jpgjs/issues/13][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3390

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
status-firefox23: --- → affected
Fixed by bug 888635.
status-firefox24: --- → affected
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.