NoSquint not available for SeaMonkey 2.1 and up

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
8 months ago

People

(Reporter: rnfolsom, Unassigned)

Tracking

SeaMonkey 2.10 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14
Build ID: 20110420224920

Steps to reproduce:

When SeaMonkey 2.1 came out, I read the documentation and learned that version 2.1 would not work with Philip Chee's port of NoSquint to SeaMonkey.

So I continued using the last SeaMonkey 2.0.x version, 2.0.14.

And as later SeaMonkey versions arrived, I checked their documentation and saw no evidence that NoSquint would work on those later versions.  I have continued using SM 2.0.14.



Actual results:

On several occasions, including today, I went to
http://xsidebar.mozdev.org/modifiedmisc.html
and clicked on the NoSquint item listed in a green column on the right side of the page.
I single clicked, and later I double clicked, on "No Squint," but in either case the only result was a change in the location to
http://xsidebar.mozdev.org/modifiedmisc.html#nosquint

After returning to
http://xsidebar.mozdev.org/modifiedmisc.html,
I right-clicked on NoSquint, and when I selected either Open New Window or Open New Tab, I got a duplicate of what I had previously, namely 
http://xsidebar.mozdev.org/modifiedmisc.html#nosquint

Alternatively, when I right-clicked on NoSquint and selected Save Link Target As... , I got an opportunity to save modifiedmisc.html.  I did so, and opened it, and discovered that I had saved a very long expanded text version (long column on the left) of something.  At the top of the document was a mozdev.org link, which took me to
http://www.mozdev.org/


Expected results:

In the short run, someone should fix
http://xsidebar.mozdev.org/modifiedmisc.html
so that clicking on the green column's NoSquint comes up with a message "Not available for SeaMonkey versions above 2.0.14," followed by an address for the NoSquint version that does work on SeaMonkey 2.0.14.

In the long run, someone should either port Firefox NoSquint to the current version of SeaMonkey, or create a new version.

My laptop has a high resolution UXGA (1600x1200 pixels) 15" screen, and the ability to increase (or occasionally decrease) font size without altering images by using Ctrl++ or Ctrl+- is extremely useful.  Also useful is SeaMonkey NoSquint's ability to remember font and image settings for frequently used website.

Those features ought to be available for SeaMonkey versions more recent than 2.0.14.

Given that http://www.seamonkey-project.org/ says that "The Internet browser at the core of the SeaMonkey suite uses the same rendering engine and application platform as its sibling Mozilla Firefox," creating a NoSquint for recent SeaMonkey versions surely is not impossible.

Roger Folsom

Comment 1

6 years ago
You should right-click on "nosquint-1.93.2.1-mod.xpi" & save that.
Link:>  http://downloads.mozdev.org/xsidebar/mods/nosquint-1.93.2.1-mod.xpi

In any case, it does not work in current SeaMonkey's.
And you know that.

You can change zoom settings without altering images.
And you know that.

And zoom settings can be remembered (& are by default) by domain.
And you know that.

NoSquint is a third party extension.
It would be nice if its author supported SeaMonkey.
Can't hurt to ask him again.  Maybe even point out the porting guides to him.

https://urandom.ca/nosquint/
Yes his FAQ even states he does not support SeaMonkey.
https://addons.mozilla.org/en-US/firefox/addon/nosquint/

Phil's modded version, would have to wait on Phil to update it to try to get it to work on current SeaMonkey's - if he desires.
Or anyone else, you or I included, are able to attempt that.

Comment 2

6 years ago
As you pointed out, my FAQ answers the "Will you support Seamonkey" question (https://urandom.ca/nosquint/#faq-seamonkey).

Entrepreneuring developers can fork NoSquint on GitHub (https://github.com/jtackaberry/nosquint) and submit a pull request providing Seamonkey support.  If it's minimally intrusive, I might be willing to merge it.  Alternatively, I don't mind at all if someone wants to maintain a fork specifically for Seamonkey.

Updated

6 years ago
Duplicate of this bug: 795316
(Reporter)

Comment 4

6 years ago
(In reply to Jason Tackaberry from comment #2)
> . . .  
> Entrepreneuring developers can fork NoSquint on GitHub
> (https://github.com/jtackaberry/nosquint) and submit a pull request
> providing Seamonkey support.  If it's minimally intrusive, I might be
> willing to merge it.  Alternatively, I don't mind at all if someone wants to
> maintain a fork specifically for Seamonkey.

To Jason Tackaberry:

As someone with no programming skills (or time), I don't know what a "pull request" is or what a "fork specifically for SeaMonkey" is, except that they apparently could be steps toward a NoSquint version for the latest SeaMonkey versions.  But if your "support" word means financial support, I would be happy to contribute to that.  All I need is for some developer to ask me to help finance (or totally finance depending on the cost) development of a SeaMonkey NoSquint.

Incidentally, your FAQs at https://github.com/jtackaberry/nosquint include a very interesting description of Firefox NoSquint:  "NoSquint is a Firefox add-on that allows you to adjust the text-only and full-page zoom levels as well as color settings both globally (for all sites) and per site."

The Philip Chee NoSquint version that I am using (in SeaMonkey 2.0.14) doesn't have (to the best of my knowledge) a color settings adjustment.  Personally I would be very happy with a simpler NoSquint version that didn't include color settings and dealt only with text.  (After looking at my 2.0.14 View menu's global setting, I don't recall whether the global settings are part of SeaMonkey 2.0.14 itself, or came from Philip Chee's port of NoSquint.)

R.N. (Roger) Folsom
Not a SeaMonkey problem imho so should be closed anyway but Isaac made a port available:

https://github.com/IsaacSchemm/nosquint/releases
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.