home and bookmarks are switched in personal toolbar

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
P5
minor
RESOLVED WONTFIX
17 years ago
13 years ago

People

(Reporter: ratman, Assigned: Biesinger)

Tracking

({polish})

Trunk
Future
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
using win32 mtrunk installer build 2001041804.

nothing more to say, really.  the home button is left of the bookmarks button,
instead of being on its right.  alphabetic order, and the such.  4xp too.

who would switch their positions intentionally?  maybe someone with deep-seated
psychological issues surrounding childhood and family who doesn't want people to
find their way home.  maybe i'll file a bug on that later.
(Reporter)

Updated

17 years ago
Keywords: 4xp, correctness

Comment 1

17 years ago
confirming on linux 2001041809
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 95 → All
Hardware: PC → All
->bookmarks
Assignee: blakeross → ben
Component: XP Apps: GUI Features → Bookmarks
QA Contact: sairuh → claudius
(Reporter)

Comment 3

17 years ago
ben - was there a reason you changed this (in fix for bug 17920)?  if not, i
figure moving lines 203-10 of navigator.xul down some should work just fine, right?

or, as noted previously, is there "something else" going on?

Comment 4

17 years ago
Fixed today.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
Since build from 2001/05/23 (and the new home icon), the home and bookmark are
once again swapped in the personal toolbar.
(Reporter)

Comment 6

17 years ago
confirm the previous comment for all builds through moz0.9.2 (win32 full
installer) and likely all nightlies to date (i haven't checked for sure yet). 
home should be treated as the first personal toolbar bookmark, on the right of
the bookmarks folder.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

17 years ago
*** Bug 85032 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

17 years ago
this bug is way too easy to fix and has been sitting around for way too long for
it not to be fixed by moz1.0.

should this bug be in user interface design?  ccing zach and mpt just in case.

Comment 9

17 years ago
Home shouldn't be in the Bookmarks Bar (aka the Personal Toolbar) in the first 
place, it should be in the main Toolbar. While it's in the Personal Toolbar, I 
don't think it really matters which side of the Bookmarks button it's on.

Comment 10

17 years ago
It does matter which side its on - items such as 'home' and, in the commercial 
builds, 'shopping' or whatever else the vendor decides to add, will shift the 
bookmarks button to the right as each is added. 
It is essential that a feature as frequently used as 'bookmarks' should remain 
in the one place. Besides, its more aesthetically pleasing to have the 
large 'bookmarks' button to the left and the smaller buttons to follow.

No doubt someone will tell me I should fix this one myself, but surely this bug 
can be solved fairly easily? Unless a major (and, I believe, necessary) revamp 
of the personal toolbar is planned anytime soon?
Sorry for the spam and all that, but there are perhaps one too many 'simple' 
bugs cluttering up bugzilla that should probably be resolved before 1.0

Updated

17 years ago
Blocks: 92997
(Reporter)

Comment 11

17 years ago
still seen with win32 trunk sea installer build 2001073103.

as i mentioned in my comment from 4-19-2001, this is a simple matter of line
order shift in navigator.xul - to be specific, currently lines 211-217 need to
be moved down to line 236.  i would put up a diff, but i still can't get cvs to
work on my computer.  

could somebody make this diff and get it checked in?

and can we get a target milestone of 1.0 too?


oh, and to add to previous comments - this is a 4xp issue as well, another good
reason this bug has been filed with bug 92997.
Created attachment 47790 [details] [diff] [review]
Patch which should place Home after Bookmarks
The above patch should fix this, any comments?
OK, I tried the patch, and it works.

Comment 15

17 years ago
> It does matter which side its on - items such as 'home'

As I said, Home should be in the main Toolbar.

>                                                         and, in the
> commercial builds, 'shopping' or whatever else the vendor decides to add,
> will shift the bookmarks button to the right as each is added.

Well, don't add those items then. Duh. To have two bookmarks-related things 
(the Bookmarks button, and the PT bookmarks) separated by non-bookmarks items 
would be marginally worse than having a shifting Bookmarks button.
(Reporter)

Comment 16

17 years ago
confirm patch works on moz0.9.3 win32 full installer.

the only "non-bookmark" button between the bookmarks folder and the personal
toolbar bookmarks should be the home button, on mozilla releases.  however, we
do have to keep in mind that the mozilla project is intended as a developer
platform, and that developers (like, say, netscape) will put their own linked
icons by the bookmarks folder.  a bookmarks folder fixed on the left margin will
provide for a somewhat more universal appearance.

furthermore, i have yet to see a single reason as to why home has been moved
before the bookmarks folder, *twice* now.  the original mozilla builds (pre m18)
and netscape 4.x always had the bookmarks folder fixed at the left margin. 
since the home button is a link to a url, it should at least be next to the
other personal toolbar links, if it can't be on the navigator toolbar.

seeing as there is no conceivable gain by affixing the home button where it is
now, this change should never have been made in the first place, and needs to be
reversed.


i know i should be laughing that something like this is being argued at all, but
i'm saddened instead.  oh well.
Keywords: patch, polish, qawanted
mpt, that is not really a reason for not putting the Bookmarks button to the 
left. Can you give a good reason for not applying that patch?


In the meantime, could someone maybe give an r= on this patch?
Status: REOPENED → ASSIGNED
Target Milestone: --- → Future

Comment 18

17 years ago
the patch is fine, r=zach@zachlipton.com on that, in terms of if we should 
use it or not, that's mpt's call. I can try to round up an sr if mpt says YES
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 20

17 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0

Comment 21

17 years ago
From a UI point-pf-view, it makes since to have the "Home" button separated from
the other user-definable buttons.  "Home" is a special button that doesn't
operate like the rest - when the user drags a URL to the home button, they
receive a dialog asking whether they want that URL to become their home page.  

This special behavior has to be somehow identified by some sort of special
positioning.  Currently, that's by placing the "Home" button on its own, left of
the Bookmarks button.  If the Home button is moved, make sure that something
identifies that it's "not just another link"

Comment 22

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 23

16 years ago
remove self

Comment 24

14 years ago
Jan, pch:
how about WONTFIXing this? Neil is not opposed, biesi doesn't mind anymore.
So now getting your opinion on this old issue.

Putting the Home button on a different toolbar is a goal desired by several
people, but that is not this bug and is not affected by any resolution of this one.

Comment 25

14 years ago
(In reply to comment #24)
> pch:
I am no more involved in the suite UI.
Product: Browser → Seamonkey

Comment 26

13 years ago
Dave, Jan - OK to mark this WONTFIX ?

Comment 27

13 years ago
==> biesi
Assignee: bugs → cbiesinger
QA Contact: claudius → bookmarks

Updated

13 years ago
Keywords: qawanted

Comment 28

13 years ago
(In reply to comment #26)
> Dave, Jan - OK to mark this WONTFIX ?

I agree. Like comment #21 I think the Home button is different to the Bookmarks
button and the bookmarks that come to their right. It makes sense to keep the
Bookmarks button and bookmarks together so Home should be the one furthest left.

It has also been this way for so long that it would cause problems for any
developers still using SeaMonkey as the basis of their project.
Status: NEW → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.