SendTabActivity leaks PII (URI sent to client)

RESOLVED FIXED in mozilla17

Status

()

P1
normal
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: nalexander, Assigned: nalexander)

Tracking

unspecified
mozilla17
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I FxSync(29199)               SendTabActivity :: Send was clicked.
I FxSync(29199)               Command :: Sending URI to client: http://www.reddit.com/ -> wZnQMxjo6hXY (Fennec Start)
I FxSync(29199)               Command :: Sending displayURI to wZnQMxjo6hXY
Priority: P2 → P1
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 767596
(Assignee)

Comment 2

6 years ago
We missed this one.
Assignee: nobody → nalexander
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f276e0c24f01
Status: REOPENED → ASSIGNED
Target Milestone: --- → mozilla17

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/f276e0c24f01
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 773406
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

a year ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.