Closed Bug 766385 Opened 8 years ago Closed 8 years ago

[adbe 3215926] Stage3D and StageVideo content Flash to not render when open in multiple tabs in Firefox 13 on Windows Vista only

Categories

(Core :: Plug-ins, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
firefox14 - wontfix
firefox15 - ---

People

(Reporter: smadayag, Unassigned)

Details

Attachments

(6 files)

Attached file media
Method:
1.) Open 2 tabs in FF13 of the following (media attached):
BasicTriangleRotate_smoke.html
BasicTriangleRotate_smoke.html
2.) Go back to the first tab and refresh the page

Result:
Flash will not render at all, not just the Stage3D content
Attached file media html
OS: Mac OS X → Windows Vista
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Are all versions of Flash affected? Adding qawanted and regressionwindow-wanted on our side to reproduce, and tracking for upcoming versions of Firefox.
more info provided by dev/qe (dxdiag attached of macine that reproduces the issue)

When StageVideo or Stage3D content is present on 2 or more tabs only one will render anything.  This happens only in Firefox 13, FF 12 is fine.  Issue reproduces with 11.2+.  The only configuration we could find that this reproduces on: 
Vista 32-bit Service Pack 2
Intel Core 2 Extreme X9650 @3.00Ghz
Nvidia 8800 GTX, Driver 8.17.0013.0142
Firefox 13.0 and 13.0.1
Note, setting 'Use hardware acceleration when available'  to false in FF13 makes the issue go away.  Seems to be a conflict between FF's use of the GPU and Flash's, at least for this particular gpu/driver config.   No idea how widespread this problem is.       The bug does not reproduce on IE9 on the same machine (which also uses a gpu compositing model).
Unable to reproduce with Firefox 13.0 with Flash 11.3r300 running on Windows 8 RP 64-bit with an NVidia 8600GT Driver 301.42 (5/22/2012).

What happens when you update to the latest driver?
http://www.geforce.com/drivers/results/44966

Note that I realize I'm not using the exact same environment, but it is still win32. Since hardware acceleration seems to be a requirement here, I cannot test in my Vista32 VM.

I know QA has a Vista machine in our lab but it has an ATI card in it. This may have to wait until Monday when someone in Mountain View can check. If this does require an Nvidia 8* Series card, it may be even harder to track down.

If there's any information people can share that make the test requirements less restrictive, it would go a long way in helping QA test this bug.
response inline from aaron on our side:

What happens when you update to the latest driver?
http://www.geforce.com/drivers/results/44966
-Latest driver is installed, issue reproduces
 
If there's any information people can share that make the test requirements less restrictive, it would go a long way in helping QA test this bug.
-Unfortunately that is the only configuration that has reproduced the issue.  ATI cards on Vista 32bit have not reproduced nor an NVIDIA Quadro FX 1700. 
 
Thanks,
Aaron
Have you been able to reproduce with any other NVidia cards? If it's reproducible with something we can buy off the shelf today, it would be easy enough for us to get someone to run out and get a card to put in our Vista machine. I don't believe Nvidia 8800GT are readily available anymore.
We have someone who is going to bring in a graphics card that matches what is mentioned here. As soon as we get it, likely tomorrow, we'll test this.
We were able to set up an Intel machine with Vista 32bit and a NVIDIA GeForce 8800 GTX graphics card with the latest drivers. I tried Fx12 and 13, but I don't see any difference in behavior. I can play Flash content in multiple tabs, while loading the media in comment #0, but it's not clear what the problem is.

One thing worth noting is that after installing the card and the drivers it displayed a message saying it was defaulting to a lower performance setting because it needed its own connection to the power supply (which I thought I did).

I'm attaching what I see when I load the media in comment #0 and information about this machine.
aaron took a look to see what would happen if the gpu was not plugged in...  the machine wouldn't actually start. he suggests using a larger power supply, either swapping out or using another box with one.
Sal, the graphics card in question has two sockets where I can plug in power. I tried both. With one of them, the machine would not boot. With the other it booted fine, but I got the message I described in comment #10. Dxdiag said there were no problems with it though.

I'll try to put it in a different machine.
you'll need to find a power supply to power both 6-bin slots.  we believe that's why you are getting the error about running at a lower performance setting...
I was able to get a power supply splitter to connect to the two slots and now the graphics card is working fully. I tested 3d video as well, and everything seems to be working fine.

I still cannot reproduce this problem. If I'm supposed to see a triangle in the media linked to here, I never see it.

I have no problems with other Flash content, like playing multiple youtube videos in different tabs.

Sal, could you point me to different media?
Removing qawanted from the keywords because we've done a reasonable effort in investigating this. We can add it back when we get more information.
Keywords: qawanted
per aaron, i think it would be fine to close this down as unable to reproduce.  thanks.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.