Closed Bug 766392 Opened 10 years ago Closed 10 years ago

Persist the reference to marketplace on about:apps even when apps are installed on about:apps

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P2)

ARM
Android
defect

Tracking

(firefox16 verified, firefox17 verified)

VERIFIED FIXED
Firefox 17
Tracking Status
firefox16 --- verified
firefox17 --- verified

People

(Reporter: jsmith, Assigned: wesj)

References

Details

Attachments

(3 files, 2 obsolete files)

Right now, the reference to marketplace is only shown if there are no apps installed. We should persist this link permanently on the about:apps page to allow a user to easily get to the marketplace when viewing their apps they have installed.
Attached image WIP Screenshot (obsolete) —
I think this page needs a small redesign to better match our other about pages anyway. Something kinda like this. Note we have that exact same icon in the upper right on about:addons, except there it links to AMO. Here it can link to the marketplace. And we should probably at the same time fix this disconnect between addons and apps using the same icon?

In both cases, its not obvious its a link. So we need to think of/design something a bit smarter. Add an arrow, or make it look more like a clickable button?
k9o nomination - important implementation for fennec native app management
blocking-kilimanjaro: --- → ?
No longer blocks: Blocking-FFA-WebRT1+
blocking-kilimanjaro: ? → ---
QA Contact: aaron.train
Priority: -- → P2
Attached patch WIP Patch (obsolete) — Splinter Review
Looking at this again. I really want to slip things off into a base style, so that's what I'm doing.
Attachment #634687 - Attachment is obsolete: true
Attached patch PatchSplinter Review
I want this for any previews. This is the simplest way to get to it I think. I'll post some screenshots....
Assignee: nobody → wjohnston
Attachment #644101 - Attachment is obsolete: true
Attachment #649497 - Flags: review?(mark.finkle)
Attached image Screenshot with an app
Attached image Screenshot with no apps
No apps. This text might be too small? We can try this and increase it if it is.
Much cleaner look and feel overall. I like it.
Comment on attachment 649497 [details] [diff] [review]
Patch

This gets us much closer to the other about pages. We can tweak more in followups.
Attachment #649497 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 770726
Verified on mozilla-inbound (17)
https://hg.mozilla.org/mozilla-central/rev/1bb507f20428
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
Comment on attachment 649497 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Original about:apps impelementation
User impact if declined: about:apps doesn't look like our other about pages, lacks a persistent reference to the store.
Testing completed (on m-c, etc.): landed on mc this 8/1
Risk to taking this patch (and alternatives if risky): Very low risk. Mostly visual clean up
String or UUID changes made by this patch: None.
Attachment #649497 - Flags: approval-mozilla-aurora?
Attachment #649497 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Version: unspecified → Trunk
Status: RESOLVED → VERIFIED
Checkin for Aurora, right?
Keywords: checkin-needed
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.