Last Comment Bug 766411 - [otoro] DBus communication with bluetooth does not work on otoro
: [otoro] DBus communication with bluetooth does not work on otoro
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: b2g-bluetooth
  Show dependency treegraph
 
Reported: 2012-06-19 17:48 PDT by Kyle Machulis [:qdot]
Modified: 2012-07-18 13:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
+


Attachments

Description Kyle Machulis [:qdot] 2012-06-19 17:48:31 PDT
DBus communication with the bluez core does not work on otoro. We can bring up bluetooth firmware on the otoro device, and can successfully scan for devices via low level commands thru hcitool, but actual gecko communication does not work. This is most likely due to the mix of dbus/bluez library and kernel versions on the phone at the moment.
Comment 1 Kyle Machulis [:qdot] 2012-07-17 20:46:18 PDT
confirmed working by echou as of kernelupdate5
Comment 2 Kyle Machulis [:qdot] 2012-07-18 13:25:06 PDT
And also as of kernelupdate6. Closing.

Note You need to log in before you can comment on or make changes to this bug.