Closed Bug 766422 Opened 8 years ago Closed 2 years ago

"ABORT: Framebuffer not complete" with perspective, skew, -moz-hidden-unscrollable

Categories

(Core :: Graphics, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Assigned: jgilbert)

References

Details

(Keywords: assertion, testcase)

Attachments

(3 files)

No description provided.
Attached file stack trace
As in Bug 746730, we're calling LayerManagerOGL::CreateFBOWithTexture with a rather large framebuffer rect (7583 x 6). Presumably 7583 is larger than your GPU's maximum texture size (which GPU do you have?), so texture creation fails and we wind up with an incomplete framebuffer. As in Bug 746730, a possible fix is to cap the size of the framebuffer rect to the maximum texture size (see Bug 746730, Comment 9).
> which GPU do you have?

According to about:support, my macbook pro has:

"ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine -- 2.1 ATI-7.18.18"
(In reply to Jesse Ruderman from comment #3)
> > which GPU do you have?
> 
> According to about:support, my macbook pro has:
> 
> "ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine -- 2.1
> ATI-7.18.18"

According to https://developer.apple.com/graphicsimaging/opengl/capabilities/GLInfo_1068.html, the maximum texture size on that GPU is 16384. But perhaps your MacBook was using its integrated GPU at the time of the crash (I can reproduce the crash on my MacBook when using the integrated GPU, but not when using the discrete GPU).
I can confirm that the testcase uploaded in this bug report crashes Firefox 16 (nighty, updated) instantly. Also when signing-in or signing-off to icloud.com Firefox 16 crashes regularly (1 in 5 times, sometimes even less often). The console message printed is almost exactly the same in the icloud.com and the testcase crash.

I have a MacBook 13' with an Intel GMA 950 graphics chipset running Snow Leopard 10.6.8.

In bug 705641 I have reported that Firefox 16 didn't crash with icloud.com. After updating nightly (via automatic updater) and testing multiple times Firefox 16 crashed. Maybe that happened because this crash doesn't happen all the time and needs multiple tests. Thankfully the testcase uploaded here crashes every time. I will try to provide more info if you want me to.
(In reply to bugecho from comment #5)
> I have a MacBook 13' with an Intel GMA 950 graphics chipset running Snow
> Leopard 10.6.8.

The maximum texture size on a GMA 950 is only 2048, so texture creation is failing when LayerManagerOGL::CreateFBOWithTexture is called with a frambuffer rect of size 7583 x 6.
(In reply to Ali Juma [:ajuma] from comment #6)
> The maximum texture size on a GMA 950 is only 2048, so texture creation is
> failing when LayerManagerOGL::CreateFBOWithTexture is called with a
> frambuffer rect of size 7583 x 6.

So that means that there is no way to prevent this kind of crashes with a GMA 950 and Firefox's hardware acceleration enabled?

(I understand that the GMA 950 is a very outdated graphics chip but Firefox's hardware acceleration is enabled by default and it works exceptionally well (apart from these crashes of course) and makes Firefox by far the best performing browser on my system. For example I get almost 20fps more in the "Hardware Acceleration Stress Test" than other browsers.)
(In reply to bugecho from comment #7)
> (In reply to Ali Juma [:ajuma] from comment #6)
> > The maximum texture size on a GMA 950 is only 2048, so texture creation is
> > failing when LayerManagerOGL::CreateFBOWithTexture is called with a
> > frambuffer rect of size 7583 x 6.
> 
> So that means that there is no way to prevent this kind of crashes with a
> GMA 950 and Firefox's hardware acceleration enabled?

We can prevent it by making sure the framebuffer rect is never larger than the maximum texture size (which we can do by following the approach in Bug 746730, Comment 9).
Is this still reproducible?
Flags: needinfo?(jruderman)
WFM.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jruderman)
Resolution: --- → WORKSFORME
Actually, I still see this on my Mid-2011 Mac Mini.  Its graphics card is
"Intel HD Graphics 3000 512 MB".
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I can confirm that the test case still insta-crashes on Aurora 19.0a2 (2012-12-12) on my month-old macbook air, with an Intel HD Graphics 4000 512 MB.
Jeff, can you take this or get Milan to find someone else to take it? :-)
Assignee: nobody → jgilbert
No longer reproduces on trunk.
Status: REOPENED → RESOLVED
Closed: 7 years ago2 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.