wifiManager.connectionInfoUpdate does not fire every 5 sec as said on IDL

RESOLVED FIXED

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #764682 +++

STR:

Do whatever you want to make the B2G phone connect to a wifi network.

Expected:

The icon appears on the status bar, and show the signal strength.

Actual:

Icon appears but very dark since it always indicates 0 signal strength.

Note:

IDL: http://mxr.mozilla.org/mozilla-central/source/dom/wifi/nsIWifi.idl#109

The icon gets to appear because |wifiManager.connection.network| is not null and because wifiManager.onstatuschange fires correctly. But wifiManager.connectionInfoUpdate does not.

Upon further inspection with dump() I found that wifiManager.connectionInfoUpdate is only triggered twice right after "associated" and "connected" state. This is not expected.
So, I think this was on the otoro before the wifi worked on it. If so, this should be fixed now. Tim, please reopen if it isn't.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Should I verify this against hg m-c or mozilla-b2g m-c?
OK. I tested out two combinations:

1) SGS2 with lastest hg m-c
2) Otoro with latest mozilla-b2g m-c

None of them fires |connectionInfoUpdate| every 5 secs.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This was fix some day ago.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.