Can't relaunch without reboot on WinME

VERIFIED DUPLICATE of bug 53952

Status

P2
major
VERIFIED DUPLICATE of bug 53952
18 years ago
14 years ago

People

(Reporter: lord, Assigned: law)

Tracking

Trunk
mozilla0.9.2
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
At home, I'm running a recent build of Mozilla on WinME.  

If I crash or close the Mozilla client, I sometimes cannot restart it.  I click
on the icon, the hourglass appear, a Mozilla process gets started, but nothing
happens.  I don't even get the splashscreen.  I've let it sit for a long time
with no results.  Killing that process and trying again does not help either.

The only solution I've found is to reboot the machine.  Then Mozilla launches as
normal.

This never happens on my Win2k machine.  It happens on my WinME machine daily.

Updated

18 years ago
Severity: normal → major
OS: Windows 2000 → Windows ME

Comment 1

18 years ago
could you please follow the steps at 
http://www.mozilla.org/quality/help/dependency-walker.html and attach a zip 
(application/zip) of dwi files from a normal and hung mozilla? 

Updated

18 years ago
Whiteboard: catfood
(Reporter)

Comment 2

18 years ago
When this happened just now, I tried to reboot the system.  The system reported
that the process "NSPR event receiver" was not responding.  I killed it, and
Mozilla started up.

Comment 3

18 years ago
"NSPR event receiver" is no longer part of NSPR.  It is in
xpcom/threads now (in the files plevent.h and plevent.h).

Comment 4

18 years ago
pass onto vishy... maybe he or someone on his team can investigate...
Assignee: asa → vishy
Do you see mozilla.exe or netscp6.exe left around in your task manager? i.e. the
process never really exited? 
(Reporter)

Comment 6

18 years ago
Usually no.  There are those cases where a process has not closed down, but this
is a different case.

Since I run into the problem almost daily, I wonder how long it would take to
reproduce it.  I'm probably being too hopeful, but maybe having someone
open/close the client a few dozen times on WinME would do the trick.  I suspect
that's not sufficient to trigger this problem, but it might be worth a try.


Comment 7

18 years ago
*** Bug 79870 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: nsbeta1

Comment 8

18 years ago
nav triage team:

Paul, can you try to reproduce this on one of our inhouse ME machines
thats a good point. reassigning to law who owns 53952. 
Assignee: vishy → law

Updated

18 years ago
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla0.9.2

Comment 11

18 years ago
*** Bug 77721 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Priority: -- → P2
Whiteboard: catfood
Lisa - do you know who has an windows ME box that we can use to reproduce this 
problem? thanks, Vishy

Comment 13

18 years ago
Yes, nbaca has one.  Please contact her.
(Assignee)

Comment 14

18 years ago
I'm willing to bet that this is (was) a dup of bug 53952.  If you can reproduce 
in a current build, please re-open.

*** This bug has been marked as a duplicate of 53952 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 15

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.