Last Comment Bug 766654 - Pasting a URL into download manager to start a download does not work with the new download panel
: Pasting a URL into download manager to start a download does not work with th...
Status: VERIFIED FIXED
: regression, ux-efficiency
Product: Firefox
Classification: Client Software
Component: Downloads Panel (show other bugs)
: 16 Branch
: All All
: -- normal with 1 vote (vote)
: Firefox 19
Assigned To: Mike Conley (:mconley) - (Away until June 29th)
:
Mentors:
Depends on:
Blocks: DownloadsPanel ReleaseDownloadsPane
  Show dependency treegraph
 
Reported: 2012-06-20 11:38 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-12-03 08:53 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP Patch 1 (4.36 KB, patch)
2012-11-07 19:11 PST, Mike Conley (:mconley) - (Away until June 29th)
no flags Details | Diff | Review
Patch v1 (5.42 KB, patch)
2012-11-09 11:17 PST, Mike Conley (:mconley) - (Away until June 29th)
mak77: review+
Details | Diff | Review
Patch v2 (r+'d by mak) (5.38 KB, patch)
2012-11-13 11:40 PST, Mike Conley (:mconley) - (Away until June 29th)
no flags Details | Diff | Review

Description Matt Brubeck (:mbrubeck) 2012-06-20 11:38:52 PDT
In the old download manager, pasting a URL causes Firefox to download a URL.  This shortcut is useful because it's the one of the only ways to make Firefox start a download immediately rather than loading and viewing the URL.  This is no longer possible in the new downloads panel UI.
Comment 1 Marco Bonardo [::mak] 2012-11-06 08:02:15 PST
loss of functionality
Comment 2 Mike Conley (:mconley) - (Away until June 29th) 2012-11-07 19:11:32 PST
Created attachment 679520 [details] [diff] [review]
WIP Patch 1

Checkpointing work here for the night. I still have a few focus issues to work out, but this basically works.
Comment 3 Mike Conley (:mconley) - (Away until June 29th) 2012-11-09 11:17:20 PST
Created attachment 680158 [details] [diff] [review]
Patch v1

Here's my first run at this.
Comment 4 Marco Bonardo [::mak] 2012-11-13 09:54:11 PST
Comment on attachment 680158 [details] [diff] [review]
Patch v1

Review of attachment 680158 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/downloads/content/downloads.js
@@ +308,5 @@
> +#else
> +                  aEvent.ctrlKey;
> +#endif
> +
> +    if (pasting) {

invert this and early return, so less indentation.

@@ +330,5 @@
> +        if (!url) {
> +          return;
> +        }
> +
> +        let uri = Services.io.newURI(url, null, null);

nit: lots of empty space above, maybe compact code a bit
Comment 5 Mike Conley (:mconley) - (Away until June 29th) 2012-11-13 11:40:37 PST
Created attachment 681148 [details] [diff] [review]
Patch v2 (r+'d by mak)

Thanks for the r+! Requested changes made.
Comment 6 Mike Conley (:mconley) - (Away until June 29th) 2012-11-13 12:15:52 PST
Landed on mozilla-inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/242334181a9d
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-11-13 16:08:06 PST
https://hg.mozilla.org/mozilla-central/rev/242334181a9d
Comment 8 Simona B [:simonab] 2012-12-03 08:53:54 PST
Verified as fixed on the latest Nightly - pasting a URL in the downloads panel starts the download.

Verified on Ubuntu 12.10, Mac OS X 10.7 and Windows 7:
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121203 Firefox/20.0 Build ID: 20121203030801
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20121203 Firefox/20.0 Build ID: 20121203030801
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20121202 Firefox/20.0 Build ID: 20121202030723

Note You need to log in before you can comment on or make changes to this bug.