Last Comment Bug 766664 - make double-including package-name.mk not break things
: make double-including package-name.mk not break things
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
Depends on:
Blocks: 723946
  Show dependency treegraph
 
Reported: 2012-06-20 11:56 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-07-23 13:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
make double-including package-name.mk not break things (1.84 KB, patch)
2012-06-20 11:56 PDT, Ted Mielczarek [:ted.mielczarek]
mh+mozilla: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Ted Mielczarek [:ted.mielczarek] 2012-06-20 11:56:12 PDT
Currently package-name.mk gets double-included in a few places, which breaks using MOZ_PKG_SPECIAL.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-06-20 11:56:19 PDT
Created attachment 634995 [details] [diff] [review]
make double-including package-name.mk not break things
Comment 2 Mike Hommey [:glandium] 2012-06-20 11:58:29 PDT
Comment on attachment 634995 [details] [diff] [review]
make double-including package-name.mk not break things

Review of attachment 634995 [details] [diff] [review]:
-----------------------------------------------------------------

Is that enough for the triple inclusion in the test package name?
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-06-20 12:41:07 PDT
I just tested locally and this fixes the test package name issue.

http://hg.mozilla.org/integration/mozilla-inbound/rev/8f91afcac737
Comment 4 Ed Morley [:emorley] 2012-06-21 04:05:35 PDT
https://hg.mozilla.org/mozilla-central/rev/8f91afcac737
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-07-23 09:03:29 PDT
Comment on attachment 634995 [details] [diff] [review]
make double-including package-name.mk not break things

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: packaging ARMv6 doesn't break
Testing completed (on m-c, etc.): landed on m-c when it was Fx16
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Comment 6 Ted Mielczarek [:ted.mielczarek] 2012-07-23 09:19:58 PDT
This patch is very low-risk. It's simply a correctness fix in the build system that happened to be necessary to make another patch work properly.
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-23 13:01:30 PDT
Comment on attachment 634995 [details] [diff] [review]
make double-including package-name.mk not break things

build system fix, approving.

Note You need to log in before you can comment on or make changes to this bug.