Last Comment Bug 766757 - Can't use both REPLACE_HISTORY and BYPASS_CACHE flags when calling nsIWebNavigation::loadURI()
: Can't use both REPLACE_HISTORY and BYPASS_CACHE flags when calling nsIWebNavi...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Brian Nicholson (:bnicholson)
:
Mentors:
Depends on:
Blocks: 766406
  Show dependency treegraph
 
Reported: 2012-06-20 15:35 PDT by Brian Nicholson (:bnicholson)
Modified: 2012-06-22 03:45 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add LOAD_REPLACE_BYPASS_CACHE load type (7.14 KB, patch)
2012-06-20 16:51 PDT, Brian Nicholson (:bnicholson)
bzbarsky: review+
Details | Diff | Splinter Review
Follow-up to add missing break (852 bytes, patch)
2012-06-21 14:06 PDT, Brian Nicholson (:bnicholson)
no flags Details | Diff | Splinter Review

Description Brian Nicholson (:bnicholson) 2012-06-20 15:35:40 PDT
<bz> but in any case, the upshot is that there is no valid docshell loadtype that has both flags
<bz> and docshell uses integer loadtypes instead of flag bits
<bz> so it's all kinda broken
<bz> any time you want to do a new flag combination, you have to explicitly allow it...
<bz> And in particular, nsDocShell::DoChannelLoad does a switch, not a bit check
Comment 1 Brian Nicholson (:bnicholson) 2012-06-20 16:51:12 PDT
Created attachment 635127 [details] [diff] [review]
Add LOAD_REPLACE_BYPASS_CACHE load type

This patch works for me, but I had to guess on a few things:
- whether this should be prefixed with LOAD_NORMAL or just LOAD
- what nsIDOMPerformanceNavigation type this should be considered as

This change is for the "Request Desktop Site" feature on mobile (bug 766406). If changing from a mobile->desktop version of a page, we want to make sure we aren't showing the cached mobile page, and we also don't want the same URL to be in the history twice.
Comment 2 Boris Zbarsky [:bz] 2012-06-20 16:58:01 PDT
Comment on attachment 635127 [details] [diff] [review]
Add LOAD_REPLACE_BYPASS_CACHE load type

r=me
Comment 3 Brian Nicholson (:bnicholson) 2012-06-21 10:31:43 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/48e15675e290
Comment 4 Brian Nicholson (:bnicholson) 2012-06-21 14:06:13 PDT
Created attachment 635457 [details] [diff] [review]
Follow-up to add missing break

http://hg.mozilla.org/integration/mozilla-inbound/rev/93f5a6a9474a

Note You need to log in before you can comment on or make changes to this bug.