The default bug view has changed. See this FAQ.

Exception in HUDService-content.js when the Web Console is closed during network requests

RESOLVED FIXED in Firefox 15

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Loic, Assigned: msucan)

Tracking

({regression})

Trunk
Firefox 16
regression
Points:
---

Firefox Tracking Flags

(firefox15 fixed)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:

1) Open WebGL demo http://www.jeshua.me/spectrascade/sc (wait for full loading)
2) Open the Web Console (Ctrl+Shift+K)
3) Open the Error Console (Ctrll+Shift+J)
4) Close the Web Console (with the close X button)
5) Close the browser window (not the Error console window)

Error message displayed in Error Console:

Error: NetUtil is null
Source File: chrome://browser/content/devtools/HUDService-content.js
Line: 1479
(Reporter)

Comment 1

5 years ago
Addition: it looks like step #5 is not necessary.
(Assignee)

Comment 2

5 years ago
Thanks for your bug report. I will look into this.
(Assignee)

Comment 3

5 years ago
I was able to reproduce by closing the Web Console before the page fully loaded.
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 16 Branch → Trunk
(Assignee)

Updated

5 years ago
Summary: Error: NetUtil is null Source File: chrome://browser/content/devtools/HUDService-content.js Line: 1479 → Exception in HUDService-content.js when the Web Console is closed during network requests
(Assignee)

Comment 4

5 years ago
Created attachment 636277 [details] [diff] [review]
[in-fx-team] proposed patch

Problem: NRL_onDataAvailable() continues to be called after HUDService-content.js destroys itself (once the user closes the Web Console). NetUtil and NetworkHelper are both used within NRL for keeping the network request ongoing, until it "naturally" stops. This patch no longer removes NetUtil and NetworkHelper to ensure safe functioning of NRL. This should cause no memleaks.

We probably want this in Aurora as well?
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Attachment #636277 - Flags: review?(rcampbell)
Comment on attachment 636277 [details] [diff] [review]
[in-fx-team] proposed patch

"should cause no memory leaks". Let's verify with a Try run. R+ on completion of that.
Attachment #636277 - Flags: review?(rcampbell) → review+
(Assignee)

Comment 6

5 years ago
Thank you!

Green results:
https://tbpl.mozilla.org/?tree=Try&rev=39f61221d634
(Assignee)

Comment 7

5 years ago
Comment on attachment 636277 [details] [diff] [review]
[in-fx-team] proposed patch

https://hg.mozilla.org/integration/fx-team/rev/05bd5e010835
Attachment #636277 - Attachment description: proposed patch → [in-fx-team] proposed patch
(Assignee)

Updated

5 years ago
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/05bd5e010835
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
(Assignee)

Comment 9

5 years ago
Comment on attachment 636277 [details] [diff] [review]
[in-fx-team] proposed patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 673148 - in the fight with memory leaks we ended up with nulling out some objects imported from JSM's. Network-related helper functions should not be nulled out to prevent any breakage in network request handling.
User impact if declined: If the Web Console is closed during network requests there might show an error in the error console. Otherwise, things should be fine.
Testing completed (on m-c, etc.): several green try runs, green runs in fx-team and m-c team. No problems until now.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #636277 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Keywords: regression
Comment on attachment 636277 [details] [diff] [review]
[in-fx-team] proposed patch

[Triage Comment]
Approving for Aurora 15 given this is a new regression with a near-zero risk fix.
Attachment #636277 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
Comment on attachment 636277 [details] [diff] [review]
[in-fx-team] proposed patch

Landed:
https://hg.mozilla.org/releases/mozilla-aurora/rev/01fa3762b23f

Thank you Alex!
(Assignee)

Updated

5 years ago
status-firefox15: --- → fixed
You need to log in before you can comment on or make changes to this bug.