Last Comment Bug 766821 - Clear dead wood from Bindings
: Clear dead wood from Bindings
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Nicholas Nethercote [:njn]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-20 19:13 PDT by Nicholas Nethercote [:njn]
Modified: 2012-06-22 03:44 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (16.76 KB, patch)
2012-06-20 19:13 PDT, Nicholas Nethercote [:njn]
luke: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2012-06-20 19:13:15 PDT
Created attachment 635165 [details] [diff] [review]
patch

This patch cleans up Bindings.

- It removes the unnecessary |cx| arg from Bindings() and transfer().

- It removes clone() and lastArgument(), because they are dead.

- It removes makeImmutable().  It wasn't dead, but it only contains
  assertions and the comment above its declaration was completely 
  misleading, so it didn't seem worth salvaging.
Comment 1 Luke Wagner [:luke] 2012-06-20 21:03:21 PDT
Comment on attachment 635165 [details] [diff] [review]
patch

Right on.
Comment 2 Nicholas Nethercote [:njn] 2012-06-21 15:51:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/bfa21a56f646
Comment 3 Ed Morley [:emorley] 2012-06-22 03:44:42 PDT
https://hg.mozilla.org/mozilla-central/rev/bfa21a56f646

Note You need to log in before you can comment on or make changes to this bug.