Last Comment Bug 766891 - B2G RIL: nsIRadioInterfaceLayer.DATACALL_STATE_* values is not synced with ril_consts.js
: B2G RIL: nsIRadioInterfaceLayer.DATACALL_STATE_* values is not synced with ri...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla16
Assigned To: Kan-Ru Chen [:kanru] (UTC+8)
:
Mentors:
Depends on:
Blocks: b2g-ril
  Show dependency treegraph
 
Reported: 2012-06-21 01:23 PDT by Kan-Ru Chen [:kanru] (UTC+8)
Modified: 2012-06-26 09:24 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Sync nsIRadioInterfaceLayer.DATACALL_STATE_* with ril_consts.js (1.59 KB, patch)
2012-06-21 01:31 PDT, Kan-Ru Chen [:kanru] (UTC+8)
philipp: review+
Details | Diff | Splinter Review
Remove nsIRadioInterfaceLayer.DATACALL_STATE_* (3.14 KB, patch)
2012-06-22 00:48 PDT, Kan-Ru Chen [:kanru] (UTC+8)
philipp: review+
Details | Diff | Splinter Review
Remove nsIRadioInterfaceLayer.DATACALL_STATE_* (2.52 KB, patch)
2012-06-25 23:45 PDT, Kan-Ru Chen [:kanru] (UTC+8)
no flags Details | Diff | Splinter Review

Description Kan-Ru Chen [:kanru] (UTC+8) 2012-06-21 01:23:40 PDT
And the GECKO_NETWORK_STATE_* values in ril_consts.js is synced with nsINetworkManager.NETWORK_STATE_*

Should we conciliate this to one place?
Comment 1 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-21 01:31:07 PDT
Created attachment 635222 [details] [diff] [review]
Sync nsIRadioInterfaceLayer.DATACALL_STATE_*  with ril_consts.js
Comment 2 Philipp von Weitershausen [:philikon] 2012-06-21 12:15:43 PDT
Comment on attachment 635222 [details] [diff] [review]
Sync nsIRadioInterfaceLayer.DATACALL_STATE_*  with ril_consts.js

Review of attachment 635222 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch!
Comment 3 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-21 22:55:17 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/edbb25e71396
Comment 4 Justin Wood (:Callek) 2012-06-22 00:09:54 PDT
(In reply to Philipp von Weitershausen [:philikon] from comment #2)
> Comment on attachment 635222 [details] [diff] [review]
> Sync nsIRadioInterfaceLayer.DATACALL_STATE_*  with ril_consts.js
> 

Philipp correct me if I'm wrong but we should have (also) marked the interface for iid rev given the _UNKNOWN integer value change.
Comment 5 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-22 00:13:47 PDT
Backout

https://hg.mozilla.org/integration/mozilla-inbound/rev/dced59dc1100
Comment 6 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-22 00:48:57 PDT
Created attachment 635657 [details] [diff] [review]
Remove nsIRadioInterfaceLayer.DATACALL_STATE_*

Sorry philikon, last patch was backed out because of b2g bustage. I think it's better to remove DATACALL_STATE_* completely so I made this new patch.

try: https://tbpl.mozilla.org/?tree=Try&rev=f288f07c2a25
Comment 7 Philipp von Weitershausen [:philikon] 2012-06-23 12:29:53 PDT
Ugh, I somehow read the patch as modifying ril_consts.js instead of nsIRadioInterfaceLayer. Must've been distracted, sorry.
Comment 8 Philipp von Weitershausen [:philikon] 2012-06-23 12:33:06 PDT
Comment on attachment 635657 [details] [diff] [review]
Remove nsIRadioInterfaceLayer.DATACALL_STATE_*

Review of attachment 635657 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, yes, this makes much more sense. Thanks!
Comment 9 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-25 23:45:01 PDT
Created attachment 636610 [details] [diff] [review]
Remove nsIRadioInterfaceLayer.DATACALL_STATE_*

patch bitrotted
Comment 10 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-25 23:57:00 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/14707b4a5677
Comment 11 Ed Morley [:emorley] 2012-06-26 09:24:59 PDT
https://hg.mozilla.org/mozilla-central/rev/14707b4a5677

Note You need to log in before you can comment on or make changes to this bug.