Don't show the warning triangle icon for sites with mixed content

RESOLVED FIXED in Firefox 14

Status

()

Firefox
Theme
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: shorlander, Assigned: shorlander)

Tracking

Trunk
Firefox 16
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed, firefox16 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
The warning icon is too alarming and frequent, turning up on any https site that displays http images.

Until we can differentiate between different kinds of mixed content we should just show the default globe instead of the lock.
Agreed - let's get to the right UI in the next version rather than doing this now.

Updated

5 years ago
Component: Location Bar → Theme
QA Contact: location.bar → theme
(Assignee)

Comment 2

5 years ago
Created attachment 635866 [details] [diff] [review]
Remove Mixed State Icon - Beta

[Approval Request Comment]
Bug caused by bug 747090 and bug 755429
User impact if declined: Warning icon desensitization, unnecessary anxiety and confusion about meaning
Risk to taking this patch: Low risk CSS removal and image deletion
String or UUID changes made by this patch: None
Attachment #635866 - Flags: review?(jaws)
Attachment #635866 - Flags: approval-mozilla-beta?
(Assignee)

Comment 3

5 years ago
Created attachment 635867 [details] [diff] [review]
Remove Mixed State Icon - Aurora
Attachment #635867 - Flags: review?(jaws)
(Assignee)

Comment 4

5 years ago
Created attachment 635869 [details] [diff] [review]
Remove Mixed State Icon - Nightly
Attachment #635869 - Flags: review?(jaws)

Updated

5 years ago
Attachment #635869 - Flags: review?(jaws) → review+

Updated

5 years ago
Attachment #635867 - Flags: review?(jaws) → review+

Updated

5 years ago
Attachment #635866 - Flags: review?(jaws) → review+

Updated

5 years ago
Blocks: 747090
(Assignee)

Comment 5

5 years ago
Comment on attachment 635867 [details] [diff] [review]
Remove Mixed State Icon - Aurora

[Approval Request Comment]
Bug caused by bug 747090 and bug 755429
User impact if declined: Warning icon desensitization, unnecessary anxiety and confusion about meaning
Risk to taking this patch: Low risk CSS removal and image deletion
String or UUID changes made by this patch: None
Attachment #635867 - Flags: approval-mozilla-aurora?
Attachment #635867 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 635866 [details] [diff] [review]
Remove Mixed State Icon - Beta

*stamp*
Attachment #635866 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Pushed to mozilla-inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0880a8ce3407
status-firefox16: --- → fixed
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: Firefox 14 → Firefox 16
Version: Trunk → 14 Branch
Pushed to mozilla-beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/3b1c3202112f
Assignee: nobody → shorlander
Status: NEW → ASSIGNED
status-firefox14: --- → fixed
status-firefox15: --- → affected
Pushed to mozilla-aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/2107bc8dd678
status-firefox15: affected → fixed
https://hg.mozilla.org/mozilla-central/rev/0880a8ce3407
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 16 → ---
Version: 14 Branch → Trunk

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
You need to log in before you can comment on or make changes to this bug.