Last Comment Bug 766988 - Disabling screenshot code still allows incremental screenshot updates
: Disabling screenshot code still allows incremental screenshot updates
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 16
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
: 766498 (view as bug list)
Depends on:
Blocks: 766643
  Show dependency treegraph
 
Reported: 2012-06-21 08:18 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-06-22 03:47 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (1.61 KB, patch)
2012-06-21 08:22 PDT, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Review
Patch (v2) (1.85 KB, patch)
2012-06-21 08:26 PDT, Kartikaya Gupta (email:kats@mozilla.com)
blassey.bugs: review+
Details | Diff | Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 08:18:58 PDT
Currently if you change sDisableScreenshot to true and start Fennec, you get the following exception:

06-21 15:15:34.866 W/System.err( 4982): java.lang.NullPointerException
06-21 15:15:34.866 W/System.err( 4982):     at org.mozilla.gecko.ScreenshotHandler$RepaintRunnable.addRectToRepaint(GeckoAppShell.java:2263)
06-21 15:15:34.866 W/System.err( 4982):     at org.mozilla.gecko.ScreenshotHandler.notifyPaintedRect(GeckoAppShell.java:2276)
06-21 15:15:34.866 W/System.err( 4982):     at org.mozilla.gecko.GeckoAppShell.notifyPaintedRect(GeckoAppShell.java:2192)
06-21 15:15:34.866 W/System.err( 4982):     at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
06-21 15:15:34.866 W/System.err( 4982):     at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
06-21 15:15:34.866 W/System.err( 4982):     at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
06-21 15:15:34.874 W/System.err( 4982):     at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:476)
06-21 15:15:34.874 W/System.err( 4982):     at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:90)

because sCheckerboardPageRect is set to null, but the paint listener is still running and tries to queue up dirty rects. This codepath should also check for sDisableScreenshot.
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 08:22:31 PDT
Created attachment 635323 [details] [diff] [review]
Patch
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 08:26:44 PDT
Created attachment 635328 [details] [diff] [review]
Patch (v2)

Updated patch to also take care of bug 766498 since it's pretty much the same code.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 08:27:02 PDT
*** Bug 766498 has been marked as a duplicate of this bug. ***
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 08:49:13 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7c2bab7807b3
Comment 5 Ed Morley [:emorley] 2012-06-22 03:47:31 PDT
https://hg.mozilla.org/mozilla-central/rev/7c2bab7807b3

Note You need to log in before you can comment on or make changes to this bug.