Firefox won't run JavaScript Popup pages from my hard drive pages

RESOLVED DUPLICATE of bug 204285

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 204285
6 years ago
6 years ago

People

(Reporter: Philip Karras, Unassigned)

Tracking

10 Branch
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; InfoPath.3; .NET4.0C; .NET4.0E)

Steps to reproduce:

I have an HTML page with JavaScript which needs to open another "popup" HTML page, read the innerHTML, close the page and then display the HTML in the current page again using innerHTML.



Actual results:

Firefox asks if I want to allow Popups from this "site" (my hard drive) but then doesn't accept the current "site URL" as a valid URL so it never allows my local page popups.


Expected results:

It should allow "C:\folder1\folder2\whateverfoldername\" as a a valid URL so I can allow popups from my local folders.

If you go to: http://cs.yrex.com/help/ReadFile.htm in Firefox you can see what should happen with the same files when run from a hard drive, but it doesn't.

I can't remember when this bug first appeared, Version 6? but I've been waiting forever for a fix so I can test out my JavaScript popup pages from my local drive, it is a royal pain to have to upload for each test or use IE to test with. I'm up to version 13 and still no fix.
(Reporter)

Updated

6 years ago
OS: Windows 7 → Windows XP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204285
(Reporter)

Comment 2

6 years ago
I'm glad someone keeps track of these things I couldn't find it under anything I tried in searching for it. - Thanks!
You need to log in before you can comment on or make changes to this bug.