Last Comment Bug 767024 - Building android on OS X fails due to missing readelf
: Building android on OS X fails due to missing readelf
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on:
Blocks: 763893
  Show dependency treegraph
 
Reported: 2012-06-21 09:53 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2012-06-25 02:23 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Allow dependentlibs.py to work when cross-compiling for Android on OSX (6.61 KB, patch)
2012-06-21 12:33 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 09:53:40 PDT
Trying to build android results in the following failure:

Traceback (most recent call last):
  File "/Users/kats/zspace/mozilla-git/xpcom/stub/dependentlibs.py", line 102, in <module>
    main()
  File "/Users/kats/zspace/mozilla-git/xpcom/stub/dependentlibs.py", line 99, in main
    print '\n'.join(dependentlibs(lib, options.libpaths, func))
  File "/Users/kats/zspace/mozilla-git/xpcom/stub/dependentlibs.py", line 72, in dependentlibs
    for dep in func(lib):
  File "/Users/kats/zspace/mozilla-git/xpcom/stub/dependentlibs.py", line 29, in dependentlibs_readelf
    proc = subprocess.Popen(['readelf', '-d', lib], stdout = subprocess.PIPE)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1228, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
make[5]: *** [../../dist/bin/dependentlibs.list] Error 1
make[5]: *** Deleting file `../../dist/bin/dependentlibs.list'
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2


I don't have readelf on my $PATH, which this seems to rely on.
Comment 1 Mike Hommey [:glandium] 2012-06-21 12:33:00 PDT
Created attachment 635414 [details] [diff] [review]
Allow dependentlibs.py to work when cross-compiling for Android on OSX
Comment 2 Kartikaya Gupta (email:kats@mozilla.com) 2012-06-21 12:44:02 PDT
This patch works for me. Thanks!
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-22 09:31:03 PDT
Comment on attachment 635414 [details] [diff] [review]
Allow dependentlibs.py to work when cross-compiling for Android on OSX

Review of attachment 635414 [details] [diff] [review]:
-----------------------------------------------------------------

Should you change js/src/config/autoconf.mk.in too?
Comment 4 Mike Hommey [:glandium] 2012-06-22 09:32:16 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #3)
> Comment on attachment 635414 [details] [diff] [review]
> Allow dependentlibs.py to work when cross-compiling for Android on OSX
> 
> Review of attachment 635414 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Should you change js/src/config/autoconf.mk.in too?

It's not used in js/src.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-06-23 05:46:43 PDT
https://hg.mozilla.org/mozilla-central/rev/03f1fdde2137

Note You need to log in before you can comment on or make changes to this bug.