Calling window.applicationCache.mozAdd while offline craches nightly 16.0a1

RESOLVED FIXED in mozilla16

Status

()

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: nick, Assigned: briansmith)

Tracking

16 Branch
mozilla16
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Testing caching icons for appCache enabled Developer Preview Apps Dashboard.  Using window.applicationCache.mozAdd(document.images.src[6]); causes Nightly to crash.  I noticed, it doesn't seem to crash if the parameter has successfully been added to appCache while online, though.
Hmm.. I cannot reproduce.  Can you please give me more detailed information?  Also on what application (Firefox, B2G, WebRT) do you see this behavior and what is the stack trace?  Maybe just submit that crash to crash stats and get it via about:crashes.
Desktop Firefox 16.01a.
I'll work on getting those reproduction steps.  Here's my crash report:
https://crash-stats.mozilla.com/report/index/bp-152ef638-a346-43cd-8415-1222a2120622
Please check bug 760955.  This is probably a dup of it.
Nick, is this still happening?
I don't have time to test this before summit, but I'll come back to it.
Flags: needinfo?(nick)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(nick)
Resolution: --- → FIXED
Assignee: nobody → brian
Depends on: 760955
Target Milestone: --- → mozilla16
You need to log in before you can comment on or make changes to this bug.