images not shown on webpages becuase of missing referer on image request

VERIFIED DUPLICATE of bug 74284

Status

()

Core
Networking: HTTP
--
major
VERIFIED DUPLICATE of bug 74284
17 years ago
16 years ago

People

(Reporter: Mozilla, Assigned: Stuart Parmenter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Mozilla doesn't show any images on the following sites. Both IE and NS shows the 
images just fine:
Warning! Sex sites!
http://members.bigfreehost.com/silvia/02/014.html
http://hardcore.pornbillboard.net/freepics1/1121/gal8.htm
http://www.pimpserver.com/hardcore/redlight/nikole/series.html
http://www.ftpfreehost.com/lohudra/15042/1.htm
http://hardsex.cmtgroup.com/intersexing.html

How can I debug/help? Is there a NSPR_LOG for imagelib that I can turn on?

Build 20010418

Comment 1

17 years ago
hmmm this is critical...:)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Summary: Images not shown → images not shown on webpages

Comment 2

17 years ago
probably a dup of bug 74313
74313 is very definitely X-only.  This bug is reported on Win2k...

Comment 4

17 years ago
Changing status to [imglib]
Whiteboard: [imglib]

Comment 5

17 years ago
no images is really really bad, porn sites or not...
Severity: normal → major
OS: Windows 2000 → All
Hardware: PC → All

Comment 6

17 years ago
I'm not sure this helps but perhaps..:

0[346020]: nsComponentManager: 
ContractIDToClassID(@mozilla.org/streamconv;1?from=chunked&to=unchunked)->{95ca9
8d9-2a96-48d6-a014-0dffa84834a1}
0[346020]: nsComponentManager: 
CreateInstance({95ca98d9-2a96-48d6-a014-0dffa84834a1}) succeeded
0[346020]: nsComponentManager: 
ContractIDToClassID(@mozilla.org/image/decoder;2?type=text/html)->[FAILED]

Comment 7

17 years ago
After doing some research the missing pictures are due to the missing "referer" 
header sent when fetching the image.

I made a small html page that only contained a img tag. This resulted in the 
following access log:

With Mozilla:
fw-ost.inet.tele.dk - - [03/May/2001:10:59:03 +0200] "GET /test/1.html 
HTTP/1.1" 200 50 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 
rv:0.8.1+) Gecko/20010502"
fw-ost.inet.tele.dk - - [03/May/2001:10:59:04 +0200] "GET /test/img.jpg 
HTTP/1.1" 200 3702 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 
rv:0.8.1+) Gecko/20010502"

With Internet Explorer
fw-ost.inet.tele.dk - - [03/May/2001:10:59:30 +0200] "GET /test/1.html 
HTTP/1.1" 200 50 "-" "Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)"
fw-ost.inet.tele.dk - - [03/May/2001:10:59:30 +0200] "GET /test/img.jpg 
HTTP/1.1" 200 3702 "http://gemal.dk/test/1.html" "Mozilla/4.0 (compatible; MSIE 
5.5; Windows NT 5.0)"

----------------------

What's important here is the missing referer "http://gemal.dk/test/1.html" from 
the request to the image when using Mozilla. Some servers (apparently) most 
porn servers with only let the image get shown if the referer is from the same 
site, but I've also seen this on non-porn servers.
Assignee: pavlov → neeti
Component: ImageLib → Networking: HTTP
QA Contact: tpreston → tever
Summary: images not shown on webpages → images not shown on webpages becuase of missing referer on image request
Whiteboard: [imglib]

Comment 8

17 years ago
dup of 74284

*** This bug has been marked as a duplicate of 74284 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
this is no a dupe.

Mozilla should be able to show porn...:)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 10

17 years ago
-->pavlov
Assignee: neeti → pavlov
Status: REOPENED → NEW

Comment 11

17 years ago
seems fixed....
referer is now added getting pictures on a webpage.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
qa to me.

This is a dupe, reopening to dupe.
QA Contact: tever → benc

Comment 13

17 years ago
reopening to dupe back...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 14

17 years ago
back where it belongs...

*** This bug has been marked as a duplicate of 74284 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 15

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: benc → junruh
You need to log in before you can comment on or make changes to this bug.