If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Non-lazy localizations are displayed in different language even if en-US is selected

VERIFIED FIXED in 2012-06-28

Status

Marketplace
Developer Pages
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Victor Carciu, Assigned: clouserw)

Tracking

2012-06-28
x86_64
Windows 7
Points:
---

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Prerequisites: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
Selected language is EN-US

Steps to reproduce:
1.Go to AMO developers page, submit a valid manifest, then go to the next step, details page : https://marketplace.mozilla.org/en-US/developers/submit/app/details/marble-run
2.Observe the "Device types" section

Expected results:
"Device types" text is localized for EN-US

Actual results:
"Device types" is localized in another languages.

Please see screencast for this bug: http://screencast.com/t/JyhWYNCt

NOTES:
Intermittent bug. Sometimes, the correct language is displayed.
More different languages for "Device types" observed(french, Spanish)
Not able to reproduce on staging servers.
Also look at the labels for Homepage, Support Website, and Support Email. http://cl.ly/2c3h2M232O2k1X2N2k1s

I thought this was related to the default_locale, but when I submitted an ordinary en-US manifest I could still reproduce this.
08:47 < clouserw> cvan: it's in mkt/submit/forms.py
...
08:47 < clouserw> they aren't using lazy()
...
08:48 < kumar> so the django instance starts up in French! good to know
08:48 < clouserw> oui oui
08:48 < kumar> the language of love, makes perfect sense
Summary: "Device types" is displayed in different language even if EN-US is selected. → Non-lazy localizations are displayed in different language even if en-US is selected
(Assignee)

Updated

5 years ago
Target Milestone: --- → 2012-06-28
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/f931e53904bf043e231d6f7a5e3da2d9818abd77

will go out on thursday
Assignee: nobody → clouserw
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 4

5 years ago
I was able to reproduce this issue on https://marketplace.mozilla.org/en-US/developers/ in FF17 (Win 7)
Attaching screenshot.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

5 years ago
Created attachment 646531 [details]
other locale payments
(Assignee)

Comment 6

5 years ago
same problem as before, just different strings: https://github.com/mozilla/zamboni/commit/878f25a10258bb272a3353018528e26fd77b8747
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
Verified as fixed - design changed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

5 years ago
Created attachment 665357 [details]
Postfix screenshot
You need to log in before you can comment on or make changes to this bug.