URL autocomplete suggests unexpected result, if URL contains percent-encode

NEW
Unassigned

Status

()

Firefox
Address Bar
6 years ago
a year ago

People

(Reporter: Ekanan Ketunuti, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 635729 [details]
screencast

Steps:

1. I have http://logbot.glob.com.au/?c=mozilla%23developers http://logbot.glob.com.au/?c=mozilla%23jsapi in history
2. Type "log" (w/o quote)
3. Press down arrow key to choose http://logbot.glob.com.au/?c=mozilla#jsapi
4. Press backspace key to delete "i"

Result:

autocompletes to ">> lologbot.glob.com.au/?c=mozilla#jsapi"

Expected:

autocompletes to "i"
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 566489
Resolution: --- → DUPLICATE
Duplicate of bug: 775072
(Reporter)

Comment 2

6 years ago
hmm, bug 775072 doesn't fix this bug. I still can reproduce on latest m-c nightly.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
what is "latest", the 24th August ones?
ok, I can reproduce comment 0, _while the ac panel is still open_ with the entry selected, pressing backspace completes wrongly.
Status: REOPENED → NEW
fwiw, this is "autocomplete-in-the-middle" (by the presence of >>), the bug may lay in the controller.cpp code.
that said, we should likely not complete in the middle, in this case, the % is probably confusing the comparison (we are likely comparing escaped to unescaped to figure out if we should do common autocomplete or in the middle autocomplete).

Updated

a year ago
Blocks: 1339497
You need to log in before you can comment on or make changes to this bug.