Last Comment Bug 767377 - The filtering textbox expands when entering a string
: The filtering textbox expands when entering a string
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 15 Branch
: All All
: P3 minor (vote)
: Firefox 16
Assigned To: Victor Porof [:vporof][:vp]
:
: James Long (:jlongster)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 07:45 PDT by Ioana (away)
Modified: 2012-07-16 05:26 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Dropdown content with no filters (119.37 KB, image/png)
2012-06-22 07:49 PDT, Ioana (away)
no flags Details
Filter textbox expanding (93.93 KB, image/png)
2012-06-22 07:50 PDT, Ioana (away)
no flags Details
v1 (1.26 KB, patch)
2012-07-03 09:56 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v2 (589 bytes, patch)
2012-07-15 00:19 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review
v2.1 (771 bytes, patch)
2012-07-15 03:46 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review

Description Ioana (away) 2012-06-22 07:45:10 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120621 Firefox/15.0a2 (20120621042006)

STR:
1. Load http://htmlpad.org/debugger/ in the browser.
2. Open the Debugger (Tools->Web developer->Debugger, or press Ctrl+Shift+S).
3. Select the jquery.min.js script in the dropdown.
4. Enter a "j" in the filtering textbox.

The textbox expands automatically. It's a small expansion but it's very visible to me.
Comment 1 Ioana (away) 2012-06-22 07:49:44 PDT
Created attachment 635746 [details]
Dropdown content with no filters
Comment 2 Ioana (away) 2012-06-22 07:50:21 PDT
Created attachment 635748 [details]
Filter textbox expanding
Comment 3 Victor Porof [:vporof][:vp] 2012-06-22 09:45:10 PDT
Can't reproduce this on OS X, but I think we can get away with this if we set a specific width in the CSS.
Comment 4 Victor Porof [:vporof][:vp] 2012-07-03 09:56:51 PDT
Created attachment 638778 [details] [diff] [review]
v1
Comment 5 Dão Gottwald [:dao] 2012-07-03 10:00:29 PDT
Why does this patch affect all platforms? This bug is likely due to <http://hg.mozilla.org/mozilla-central/annotate/f38d6df93cad/toolkit/themes/winstripe/global/textbox-aero.css#l7> and therefore Windows-specific.
Comment 6 Victor Porof [:vporof][:vp] 2012-07-03 13:36:00 PDT
(In reply to Dão Gottwald [:dao] from comment #5)
> Why does this patch affect all platforms? This bug is likely due to
> <http://hg.mozilla.org/mozilla-central/annotate/f38d6df93cad/toolkit/themes/
> winstripe/global/textbox-aero.css#l7> and therefore Windows-specific.

If we're going to add a width, we might as well do it on all platforms.
Is there something inherently wrong with doing so? I have no objections on fixing this only on Windows, but it would be nice to have the same sizes apply on all OS.
Comment 7 Dão Gottwald [:dao] 2012-07-03 13:41:00 PDT
<http://hg.mozilla.org/mozilla-central/annotate/f38d6df93cad/toolkit/themes/winstripe/global/textbox-aero.css#l7> affecting the textbox width is basically a toolkit bug that would ideally be fixed at a lower level rather than on a per-textbox basis. So unless the width is useful for other reasons, I think it makes sense to think of this as an interim solution that can be limited to Windows.
Comment 8 Panos Astithas [:past] 2012-07-04 03:38:35 PDT
(In reply to Dão Gottwald [:dao] from comment #7)
> <http://hg.mozilla.org/mozilla-central/annotate/f38d6df93cad/toolkit/themes/
> winstripe/global/textbox-aero.css#l7> affecting the textbox width is
> basically a toolkit bug that would ideally be fixed at a lower level rather
> than on a per-textbox basis. So unless the width is useful for other
> reasons, I think it makes sense to think of this as an interim solution that
> can be limited to Windows.

In that same line of thought it may be best to add an aero-only debugger stylesheet with this workaround. On the other hand this may be going too far.

I'm personally fine either way.
Comment 9 Victor Porof [:vporof][:vp] 2012-07-13 11:27:38 PDT
(In reply to Panos Astithas [:past] from comment #8)
> (In reply to Dão Gottwald [:dao] from comment #7)
> > <http://hg.mozilla.org/mozilla-central/annotate/f38d6df93cad/toolkit/themes/
> > winstripe/global/textbox-aero.css#l7> affecting the textbox width is
> > basically a toolkit bug that would ideally be fixed at a lower level rather
> > than on a per-textbox basis. So unless the width is useful for other
> > reasons, I think it makes sense to think of this as an interim solution that
> > can be limited to Windows.
> 
> In that same line of thought it may be best to add an aero-only debugger
> stylesheet with this workaround. On the other hand this may be going too far.
> 
> I'm personally fine either way.

Let's just add the width in the debugger win css as a temporary fix.
Or we could just not do anything and let the toolkit people to fix it? Who should we ping?
Comment 10 Victor Porof [:vporof][:vp] 2012-07-15 00:19:07 PDT
Created attachment 642345 [details] [diff] [review]
v2

Alright then.
Comment 11 Panos Astithas [:past] 2012-07-15 02:53:14 PDT
Comment on attachment 642345 [details] [diff] [review]
v2

Review of attachment 642345 [details] [diff] [review]:
-----------------------------------------------------------------

A comment that points to the bug and/or textbox-aero.css would help us remember when to get rid of it.
Comment 12 Victor Porof [:vporof][:vp] 2012-07-15 03:46:01 PDT
Created attachment 642360 [details] [diff] [review]
v2.1

Commented.
Comment 13 Panos Astithas [:past] 2012-07-15 06:44:47 PDT
https://hg.mozilla.org/integration/fx-team/rev/492fb99ae0d8
Comment 14 Ed Morley [:emorley] 2012-07-16 05:26:35 PDT
https://hg.mozilla.org/mozilla-central/rev/492fb99ae0d8

Note You need to log in before you can comment on or make changes to this bug.