The ifdefs for mDrawEventTargetFrame and mPresArenaAllocCount in nsIPresShell are not consistent. They should be.
Actually, this patch isn't right. The issue here is that mPresArenaAllocCount is defined inside NS_DEBUG, but used inside DEBUG. I don't know which one is right, but I'll update the patch if you tell me bz. :)
Summary: Make the ifdefs for mDrawEventTargetFrame and mPresArenaAllocCount consistent → Make the ifdefs for mPresArenaAllocCount consistent
Just use DEBUG.
Seems like NS_DEBUG is just an alias for DEBUG at this point. I think I'll just use Eclipse's refactoring tools to kill it, unless you tell me it still has a purpose.
That sounds great!
Summary: Make the ifdefs for mPresArenaAllocCount consistent → Kill NS_DEBUG
I went through and checked it manually, but feel free to do the same. The only line that isn't a straight s/NS_DEBUG/DEBUG/ is the one in nsDebug.h to remove the define.
Comment on attachment 635948 [details] [diff] [review] patch to kill NS_DEBUG r=me
Attachment #635948 - Flags: review?(bzbarsky) → review+
Target Milestone: --- → mozilla16
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.