Last Comment Bug 767401 - Clearing the searched token in the scripts filter should also clear the "find next" history
: Clearing the searched token in the scripts filter should also clear the "find...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 15 Branch
: All All
: P3 normal (vote)
: Firefox 16
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-22 08:37 PDT by Ioana (away)
Modified: 2012-07-16 05:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.06 KB, patch)
2012-07-03 09:41 PDT, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review
v1 (2.14 KB, patch)
2012-07-15 00:12 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review

Description Ioana (away) 2012-06-22 08:37:56 PDT
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120621 Firefox/15.0a2 (20120621042006)

STR:
1. Load http://addyosmani.github.com/todomvc/architecture-examples/backbone/index.html in the browser.
2. Type "todos#toggleDo" in the filtering textbox.
3. Clear the filtering textbox.
4. Type "todos@toggleDo" in the filtering textbox.

When using "#", the first result of the search is displayed automatically. When using "@", the first result of the search is only displayed after the user presses Enter once. 

It should work the same way for "@" as for "#": displayed the first result automatically, then show the second result when pressing Enter.
Comment 1 Victor Porof [:vporof][:vp] 2012-06-22 09:41:36 PDT
@ shouldn't work at all for now (and it should have a different meaning). The reason why it works now is more of an artifact (pressing Enter jumps to the next found token, regardless of what's written in the filtering textbox; even if you have an empty textbox, it will still jump).

Thanks for noticing this. Renaming the bug.
Comment 2 Victor Porof [:vporof][:vp] 2012-07-03 09:41:41 PDT
Created attachment 638772 [details] [diff] [review]
v1
Comment 3 Panos Astithas [:past] (away until 7/21) 2012-07-04 08:02:19 PDT
Comment on attachment 638772 [details] [diff] [review]
v1

Review of attachment 638772 [details] [diff] [review]:
-----------------------------------------------------------------

Right on!
A small test for this inside browser_dbg_scripts-searching-01.js would be appropriate.
Comment 4 Victor Porof [:vporof][:vp] 2012-07-15 00:12:40 PDT
Created attachment 642343 [details] [diff] [review]
v1

Added test.
Comment 5 Panos Astithas [:past] (away until 7/21) 2012-07-15 06:45:20 PDT
https://hg.mozilla.org/integration/fx-team/rev/6a0dfbde4089
Comment 6 Ed Morley [:emorley] 2012-07-16 05:26:31 PDT
https://hg.mozilla.org/mozilla-central/rev/6a0dfbde4089

Note You need to log in before you can comment on or make changes to this bug.