Last Comment Bug 767462 - Allow controlling outside-click event consumption with an attribute
: Allow controlling outside-click event consumption with an attribute
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on:
Blocks: 767813 767975
  Show dependency treegraph
 
Reported: 2012-06-22 10:45 PDT by Dão Gottwald [:dao]
Modified: 2013-04-22 13:42 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.11 KB, patch)
2012-06-22 10:45 PDT, Dão Gottwald [:dao]
enndeakin: review+
Details | Diff | Splinter Review
patch v2 (2.41 KB, patch)
2012-06-22 13:04 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2012-06-22 10:45:41 PDT
Created attachment 635805 [details] [diff] [review]
patch

On Windows (I don't know about other platforms) panels have a bug or misfeature that intermittently renders the previous contents when opening a panel a second time. This currently affects the identity popup (there's a bug filed, but I couldn't find it). A workaround for this is to set hidden=true when the panel hides. However, this throws the popup box object away, making previous popupBoxObject.setConsumeRollupEvent calls ineffective.
Comment 1 Dão Gottwald [:dao] 2012-06-22 10:53:42 PDT
(In reply to Dão Gottwald [:dao] from comment #0)
> This currently affects the identity popup (there's a bug filed, but I couldn't find it).

bug 684534
Comment 2 Neil Deakin 2012-06-22 11:11:25 PDT
Comment on attachment 635805 [details] [diff] [review]
patch

I'd call the attribute 'consumeclicks' (or 'consumeoutsideclicks') since there isn't really a 'rollup' event fired in either case.
Comment 3 Dão Gottwald [:dao] 2012-06-22 11:21:06 PDT
consumeoutsideclicks sounds good to me, I can use that.
Comment 4 Dão Gottwald [:dao] 2012-06-22 13:04:17 PDT
Created attachment 635877 [details] [diff] [review]
patch v2
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-06-23 05:45:39 PDT
https://hg.mozilla.org/mozilla-central/rev/16477f23e113
Comment 7 Mike Kaply [:mkaply] 2013-04-22 09:37:33 PDT
I've added documentation for this. Can someone please verify?

https://developer.mozilla.org/en-US/docs/XUL/panel#a-consumeoutsideclicks

https://developer.mozilla.org/en-US/docs/XUL/Attribute/consumeoutsideclicks

Should I add to menupopup as well? Or is it really only relevant for panels?
Comment 8 Dão Gottwald [:dao] 2013-04-22 09:55:25 PDT
You probably wouldn't want to set this on a menupopup. At least I can't think of a case where it would make sense.
Comment 9 Mike Kaply [:mkaply] 2013-04-22 13:42:40 PDT
I've made it panel only.

Note You need to log in before you can comment on or make changes to this bug.