Closed Bug 767600 Opened 10 years ago Closed 10 years ago

Long tap stops working after trying to long tap in an iframe

Categories

(Firefox for Android Graveyard :: Text Selection, defect)

ARM
Android
defect
Not set
critical

Tracking

(firefox15 verified, firefox16- verified)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox15 --- verified
firefox16 - verified

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached file logcat
I came across this while trying to test text selection, but it doesn't seem to be (at least directly) related to my code. This happens after long tapping in one of the iframes here:
http://people.mozilla.com/~mleibovic/test/text_select_iframe.html

If I try going to the awesomescreen to navigate to another page, I eventually end up with an ANR dialog.

I attached the relevant logcat. When I tried to long tap in the iframe, this is the line that appeared:
I/GeckoSubdocumentScrollHelper( 2503): Got message: Panning:Override
Wes, cc'ing you in case you have time to lend any advice here.
Severity: normal → critical
tracking-fennec: --- → ?
Attached patch patchSplinter Review
The immediate problem was caused by an infinite loop in updateCacheOffset, but after fixing that, I realized that my iframe calculations had a bunch of problems. After much thinking things through, I realized that we don't need to be computing that total scroll offset like we were, since almost all the time we just need coordinates relative to _view. The only time we really need any offset is when we're trying to compute pointInSelection in endSelection, and that isn't a scroll offset, but rather the offset of the positioning of the iframe. I made a some test pages to test this out, and it looks to be working well now:
http://people.mozilla.com/~mleibovic/test/text_select_iframe.html
http://people.mozilla.com/~mleibovic/test/two_level_iframes.html
Assignee: nobody → margaret.leibovic
Attachment #636561 - Flags: review?(mbrubeck)
Attachment #636561 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/2efe5f77b952
Target Milestone: --- → Firefox 16
https://hg.mozilla.org/mozilla-central/rev/2efe5f77b952
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This has been resolved and doesn't seem to be a regression so we won't track this.
Thus was almost certainly a regression.
Keywords: regression
Uplifted to aurora as part of a roll-up patch:
https://hg.mozilla.org/releases/mozilla-aurora/rev/2fb0a358eaf6
Component: General → Text Selection
Verified on SE Xperia mini pro with fennec 15 beta 2.
Status: RESOLVED → VERIFIED
Unable to reproduce the issue on:

Firefox Mobile 16.0b5 / Aurora 16.0a2 2012-09-26/ Nightly 17.0a1 2012-09-27
Samsung Galaxy R (Android 2.3.4)

Marking as verified on Firefox Mobile 16
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.