Last Comment Bug 767679 - IonMonkey: "Assertion failure: isObject(),"
: IonMonkey: "Assertion failure: isObject(),"
Status: RESOLVED FIXED
: assertion, regression, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: jsfunfuzz IonFuzz 721031
  Show dependency treegraph
 
Reported: 2012-06-23 00:39 PDT by Gary Kwong [:gkw] [:nth10sd]
Modified: 2013-02-07 05:18 PST (History)
6 users (show)
choller: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack (4.63 KB, text/plain)
2012-06-23 00:39 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details
fix (866 bytes, patch)
2012-07-05 13:01 PDT, David Anderson [:dvander]
sstangl: review+
Details | Diff | Splinter Review

Description Gary Kwong [:gkw] [:nth10sd] 2012-06-23 00:39:45 PDT
Created attachment 636045 [details]
stack

eval("\
    \"use strict\";\
    a();\
    function a() {\
        print\
    }\
")

asserts js debug shell on IonMonkey changeset 05a756967f25 with --ion-eager at Assertion failure: isObject(), 

Due to skipped revisions, the first bad revision could be any of:
changeset:   87140:f46cfb199e77
user:        Sean Stangl
date:        Mon Feb 06 17:15:24 2012 -0800
summary:     Make native calls faster. (Bug 721031, r=dvander)

changeset:   87141:2ce3daef5bd2
user:        Sean Stangl
date:        Mon Feb 06 17:55:48 2012 -0800
summary:     Fix warnings. (Bug 721031, red)
Comment 1 David Anderson [:dvander] 2012-07-05 13:01:54 PDT
Created attachment 639442 [details] [diff] [review]
fix
Comment 2 David Anderson [:dvander] 2012-07-10 19:50:09 PDT
This is fixed with the most recent mozilla-central merge.
Comment 3 Christian Holler (:decoder) 2013-02-07 05:18:08 PST
Automatically extracted testcase for this bug was committed:

https://hg.mozilla.org/mozilla-central/rev/2e891e0db397

Note You need to log in before you can comment on or make changes to this bug.