Last Comment Bug 767701 - Add missing nsSVGEffects::InvalidateDirectRenderingObservers() call to the clipPath code
: Add missing nsSVGEffects::InvalidateDirectRenderingObservers() call to the cl...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks: 767647
  Show dependency treegraph
 
Reported: 2012-06-23 06:15 PDT by Jonathan Watt [:jwatt]
Modified: 2012-06-23 19:57 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.09 KB, patch)
2012-06-23 06:16 PDT, Jonathan Watt [:jwatt]
longsonr: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] 2012-06-23 06:15:59 PDT

    
Comment 1 Jonathan Watt [:jwatt] 2012-06-23 06:16:55 PDT
Created attachment 636081 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] 2012-06-23 06:18:03 PDT
While addressing bug 767647 comment 2, I discovered test failures due to nsSVGClipPathFrame::AttributeChanged not invalidating its rendering observers when its transform changes.
Comment 3 Jonathan Watt [:jwatt] 2012-06-23 09:55:58 PDT
Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/057844075b23
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-06-23 19:57:08 PDT
https://hg.mozilla.org/mozilla-central/rev/057844075b23

Note You need to log in before you can comment on or make changes to this bug.