Last Comment Bug 767726 - Kill nsISVGChildFrame::DO_NOT_NOTIFY_RENDERING_OBSERVERS
: Kill nsISVGChildFrame::DO_NOT_NOTIFY_RENDERING_OBSERVERS
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-23 10:56 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-07-24 03:02 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (14.33 KB, patch)
2012-07-23 08:35 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-06-23 10:56:47 PDT
With the patch for bug 767647 we stopped invalidating rendering observers under NotifySVGChanged() since ancestor changes can't change a descendant from the point of view of the descendant's rendering observers anyway. (Since when rendering, rendering observers have the elements they reference resolve dimensions relative to them, etc., not their ancestor.)

Anyway, that bug forgot to remove DO_NOT_NOTIFY_RENDERING_OBSERVERS. It's no longer needed, so we should do that.
Comment 1 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-23 08:35:24 PDT
Created attachment 644941 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-23 09:14:09 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ce6501706d37
Comment 3 Ed Morley [:emorley] 2012-07-24 03:02:21 PDT
https://hg.mozilla.org/mozilla-central/rev/ce6501706d37

Note You need to log in before you can comment on or make changes to this bug.