[HiDPI] - updated default toolbar icons set (back, forward, reload, stop, bm manager)

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: phiw2, Assigned: phiw2)

Tracking

(Blocks: 1 bug)

1.9.2 Branch
x86
Mac OS X

Details

(Whiteboard: [camino-2.1.3])

Attachments

(4 attachments, 4 obsolete attachments)

(Assignee)

Description

6 years ago
Created attachment 636130 [details]
icons v1.2

The default toolbar set; the hide-manager icon isn't perfect yet but might look better on a real hi-dpi screen (Derek, please confirm).
Attachment #636130 - Flags: review?(alqahira)
Attachment #636130 - Flags: feedback?(dereks)
(Assignee)

Comment 1

6 years ago
Created attachment 636131 [details]
screenshot 1: Small icons, with the hidemanager icon visible

(to evaluate on non-hiDPI screens, it helps to scale the screenshot down by 50%; that is closer to what the user on a hiDPI devices actually sees, based on my experience with working between iPad/iOS simulator and the real Retina device)
(Assignee)

Comment 2

6 years ago
Created attachment 636132 [details]
screenshot 2: Large icons

Comment 3

6 years ago
The hide-manager icon looks the same between your screenshot, the tiff file in Preview, and build 20120620004357.  So I would say it doesn't look any better.
FWIW, Jon made hidemanager (bug 235863), so it's possible that he has some useful source files running around somewhere (or did you already check back when you did bug 614486?)
(Assignee)

Comment 5

6 years ago
(In reply to Derek Schrock from comment #3)
> The hide-manager icon looks the same between your screenshot, the tiff file
> in Preview, and build 20120620004357.  So I would say it doesn't look any
> better.

Is it mostly the outer part (the black/grey borders) that look blocky ? Or is the green badged part also bad ?

All other icons are OK ?

Comment 6

6 years ago
All other icons look OK.

The hide manager icon doesn't look bad it's just an icon that lacks detail.  I would agree the outer part is blocky (however so are books).  Also, the shadow might need more detail?  I don't know if the goal for this icon is to be scaled or more detailed.

Comment 7

6 years ago
I was going to comment on the shadow as well. Feels a bit harsh. Needs to be smoother or something.
Summary: [hi-dpi] - updated default toolbar icons set (back, forward, reload, stop, bm manager) → [HiDPI] - updated default toolbar icons set (back, forward, reload, stop, bm manager)
philippe, are you planning on tweaking these any based on the current feedback, or should I review them first and then you'll do all the changes at once?  (This I think is going to take a bunch more time to review than the tabs, which is part of why I still haven't gotten to it yet…not getting those blocks of time :-( and Bugzilla still doesn't have drafts ;-) [1])

[1] http://www.ardisson.org/afkar/2007/04/11/bugzilla-drafts/
(Assignee)

Comment 9

6 years ago
(In reply to Smokey Ardisson (not following bugs - do not email) from comment #8)
> philippe, are you planning on tweaking these any based on the current
> feedback, or should I review them first and then you'll do all the changes
> at once?  (This I think is going to take a bunch more time to review than
> the tabs, which is part of why I still haven't gotten to it yet…not getting
> those blocks of time :-( and Bugzilla still doesn't have drafts ;-) [1])

I'm tweaking the BM icon(s) right now. If you have comments / nitpicks / … on the other 4 icons, please let me know.
(Assignee)

Comment 10

6 years ago
Created attachment 638670 [details]
icons v1.4

Updated images with some polish a bit everywhere.
Attachment #636130 - Attachment is obsolete: true
Attachment #636131 - Attachment is obsolete: true
Attachment #636132 - Attachment is obsolete: true
Attachment #636130 - Flags: review?(alqahira)
Attachment #636130 - Flags: feedback?(dereks)
Attachment #638670 - Flags: review?(alqahira)
Attachment #638670 - Flags: feedback?(dereks)
(Assignee)

Updated

6 years ago
Attachment #638670 - Attachment description: icons v1.2 → icons v1.4
(Assignee)

Comment 11

6 years ago
Created attachment 638671 [details]
Screenshot, large size icons (HiDPI)
(Assignee)

Comment 12

6 years ago
Created attachment 638672 [details]
Screenshot, small size icons

Comment 13

6 years ago
The hidemanager icon still lacks the crispness that the the icons have.  Outside of a total design of the icon I don't think much would help? 

Also, the 24x24 and 48x48 icons don't have cut points like the 64x64.

If that doesn't bother you then everything looks good.
(Assignee)

Comment 14

6 years ago
(In reply to Derek Schrock from comment #13)
> The hidemanager icon still lacks the crispness that the the icons have. 

What part(s) of the icon look especially poor ?

> Also, the 24x24 and 48x48 icons don't have cut points like the 64x64.

That is 'by design' - for the largest icon, I added that pointy thing at the bottom of the bookmark. At smaller sizes, there aren't enough pixels available to add it (I tried it in the 48x48px icon, but even at that size, it resulted in a mess of smudged pixels). I'll try to tweak a bit mor the bottom part of the bookmark in the 48x48 icon.

Note that even on my low-dpi screen I always found that the original icon (32x32 and 24x24) lacking some crispness, particularly the outer (black) edges of the book (bottom esp).

I might try some more changes on those those outer edges first.

Comment 15

6 years ago
I agree, the bottom edge sort of blends with the shadow which kinda makes it a grey blob. 

If you look at the manager icon the shadow is a lot darker than hidemanager.  Maybe an initially darker shadow might help. 

Also, in the 64x64 icon book "lines" are 2 pixels?  What if you made them a hair darker at 1 pixel per line?  So more "lines" that are darker.
(Assignee)

Comment 16

6 years ago
Created attachment 640125 [details]
icons v1.5

Updated manager icons.
Assignee: nobody → phiw
Attachment #638670 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #638670 - Flags: review?(alqahira)
Attachment #638670 - Flags: feedback?(dereks)
Attachment #640125 - Flags: review?(alqahira)
Attachment #640125 - Flags: feedback?(dereks)
(Assignee)

Comment 17

6 years ago
Created attachment 640126 [details]
screenshot: manager icons, v1.5 (small and larger size)

Comment 18

6 years ago
Comment on attachment 640125 [details]
icons v1.5

hidemanager is nice.  Thanks.
Attachment #640125 - Flags: feedback?(dereks) → feedback+
I mid-aired with the new versions; let me just post my comments from v1.4 before I forget, with the caveat that they're for 1.4, not 1.5 ;-)  I'll try to get to hidemanager soon.

---

So, nothing to say about back, forward, stop, reload; they all look superb!

With manager, sometimes it looks like it's pixel-doubled some places; I guess that's an artifact of having an icon that has solid straight lines.  (Interestingly, to me the 48px icon seems to exhibit this more than the 64px.)  Unless you have any immediate ideas, I think they're good enough to use, though.

hidemanager :sigh: I don't know what to say.  I agree that the original hidemanager icon was never very crisp, especially the areas you identified, so we're starting with one hand already tied behind our back.  I don't think I can offer any better "areas of fuzziness" than Derek can; when I try to look at a 2x screenshot at 50%, the whole screenshot looks blurry, so that doesn't help.  And when I look at it at full size, it just looks mostly-pixel-doubled :-(  

I'm not sure more lines of "text" will help, but perhaps if the "centermost" pixel in each line is darker, as Derek suggested, there will be a smoother gradient to the lines.  But I have no idea whatsoever to suggest about the book's bottom edge :-(

The $deities of rMBPs really need to spread some around to help us out here :-P

So r=ardissone on back, forward, stop, reload, and r-unless-you-have-any-immediate-ideas on manager.
Comment on attachment 640125 [details]
icons v1.5

The 64px version of hidemanager looks like the left side of the book is curved slightly on the bottom edge near the spine, rather than straight the whole way along, but that's actually more like a real open book, so I don't think we should care.  More pixels == more photorealistic details, right? :-)

This version looks a lot smoother/better, and if Derek's happy, I'm happy, so r/icon-sr=ardissone.
Attachment #640125 - Flags: review?(alqahira) → review+
http://hg.mozilla.org/camino/rev/bf5714e44925

More pretty pixels for tomorrow's nightlies!
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [camino-2.1.3]
You need to log in before you can comment on or make changes to this bug.