Last Comment Bug 767894 - Device Storage - move test from dom/tests/mochitest/devicestorage to dom/devicestorage/
: Device Storage - move test from dom/tests/mochitest/devicestorage to dom/devi...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Doug Turner (:dougt)
:
Mentors:
Depends on:
Blocks: 761930 773798
  Show dependency treegraph
 
Reported: 2012-06-25 01:47 PDT by Doug Turner (:dougt)
Modified: 2012-07-13 14:33 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (4.43 KB, patch)
2012-06-25 01:48 PDT, Doug Turner (:dougt)
bent.mozilla: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2012-06-25 01:47:31 PDT
I am going to be adding IPC support to device storage.  part of that work requires that I create a testing ipc directory that is a peer to the tests.  at the end of the day, i want:

dom/devicestorage/tests
dom/devicestorage/ipc

This is similar to what IndexedDB does.
Comment 1 Doug Turner (:dougt) 2012-06-25 01:48:51 PDT
Created attachment 636248 [details] [diff] [review]
patch v.1
Comment 4 Doug Turner (:dougt) 2012-06-27 06:19:45 PDT
so, the reason for backout is that there is a special file that disables some tests on android native.  Paths needed to be updated there:
   mozilla-central/testing/mochitest/android.json
Comment 5 Doug Turner (:dougt) 2012-06-27 13:52:42 PDT
included the change joel pointed me to.

  https://hg.mozilla.org/integration/mozilla-inbound/rev/18f7e51126e0
Comment 6 Ed Morley [:emorley] 2012-06-28 01:08:57 PDT
https://hg.mozilla.org/mozilla-central/rev/18f7e51126e0

Note You need to log in before you can comment on or make changes to this bug.