Closed Bug 7679 Opened 25 years ago Closed 25 years ago

[PP]Sometimes windows don't refresh while displaying forms

Categories

(Core :: Layout, defect, P3)

PowerPC
Mac System 8.6
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: bam, Assigned: dcone)

Details

I've had this bug pop up numerous times while using bugzilla, but I finally
figured out a way to repeat the bug. It's a bit strange the steps you have to
go through, but it does happen other ways, just not as repeatably. If it doesn't
work the first time, please try it again. It may be a race condition. I have a
G3 macintosh, 400MHz, 128M RAM if that helps reproduce the race.

Steps to cause mozilla to stop refreshing the screen while displaying a HTML
form:

1. Start apprunner (M6 Macintosh)
2. Click the sidebar control to make it disappear.
3. Click the "bugzilla" button (under the location text entry area)
4. Click the "Enter a new bug" link.
5. Click "Browser" link.
6. Log in to bugzilla (enter userid, password, click login button)
7. Open a new mozilla window (File->New Browser Window in menu)
8. Move the original mozilla window containing the browser entry form to the
front.
9. Click in the "Description:" multiline text entry area in the bug entry form.
10. Enter more than one full line of text in the text entry area, with "return"
characters at the end of the line (ie, don't just word wrap). I just type
this is a test over and over.
11. Press return once more, and leave insert cursor in the text area at the
 beginning of a blank line (ie, don't click on anything else).
12. Choose Edit->Preferences from the menu, and drag the preferences window over
the text area in the form.

If you're lucky (?) the window containing the form will stop redisplaying. If
this is not reproducible, you may be able to find another way to reproduce it.
The elements of reproducing it seem to be, along with my confidence level that
this is a factor:

1. Multiple browser windows open at once. (fairly confident)
2. Complex forms displayed on screen, with multiline text areas and focus in
those text areas (highly confident)
3. Other windows being dragged over the form window. (highly confident)

I just found another way to reproduce it if it doesn't reproduce at first. Try
entering a little more text into the text area, and then do edit->preferences
and drag the preferences window over the form. For me, at least, eventually
doing this always results in the underlying mozilla window no longer refreshing.
[CC:ing to cpratt, so that he can determine whether or not to reassign to self.]
[CC:ing to claudius - seems like it's more his area (Mac display issues)?]
Component: Apprunner → Layout
QA Contact: leger → claudius
Assignee: don → rickg
Assignee: rickg → pierre
Pierre - please take a look.
Hardware: Macintosh → All
*** Bug 7773 has been marked as a duplicate of this bug. ***
*** Bug 7990 has been marked as a duplicate of this bug. ***
Per bug 7990, the easy way to reproduce this on Mac and Windows is to simply
bring up the preferences. A resize is necessary for the painting to occur. I
hope this can be fixed for M7.
Bugs #7773 and #7990 have been closed as duplicate of #7679 a bit lightly: these
3 bugs have nothing to do with each other.

#7679 is a difficult to reproduce Mac-specific problem where a window stops
redrawing. #7773 is a very easy to reproduce Windows-NT problem where a page
needs a resize to appear. #7990 is a more or less cross-platform problem that
describes various problems with the Prefs dialog.
Status: NEW → ASSIGNED
Hardware: All → Macintosh
Target Milestone: M9
Summary: Sometimes windows don't refresh while displaying forms → [PP]Sometimes windows don't refresh while displaying forms
Reassigned to dcone
Status: NEW → ASSIGNED
Target Milestone: M9 → M10
Target Milestone: M10 → M11
m11
Blocks: 17432
Target Milestone: M11 → M12
Target Milestone: M12 → M13
Status: ASSIGNED → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
Fixed for m12.
QA Contact: claudius → bam
bam@dimensional.com, can you verify? thanks
No longer blocks: 17432
You need to log in before you can comment on or make changes to this bug.