Last Comment Bug 768004 - IonMonkey: Don't monitor the stack value for non-ResumeAfter bailouts
: IonMonkey: Don't monitor the stack value for non-ResumeAfter bailouts
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
: 758167 (view as bug list)
Depends on:
Blocks: IonFuzz
  Show dependency treegraph
 
Reported: 2012-06-25 08:20 PDT by Jan de Mooij [:jandem]
Modified: 2012-07-30 05:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.17 KB, patch)
2012-06-25 08:20 PDT, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Review

Description Jan de Mooij [:jandem] 2012-06-25 08:20:44 PDT
Created attachment 636317 [details] [diff] [review]
Patch

decoder reported a testcase on IRC where the overrecursion check triggered a GC + invalidaton. The first opcode in the script was JSOP_GETGNAME so InvalidationBailout tried to monitor the value on top of the stack and we'd crash.

The fix is to only monitor the value for resumeAfter bailouts - in all other cases the value on the stack is invalid and we will just redo the op in the interpreter.
Comment 1 Jan de Mooij [:jandem] 2012-06-26 02:41:43 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/80a4e5dfeaaf
Comment 2 Jan de Mooij [:jandem] 2012-07-30 05:10:23 PDT
*** Bug 758167 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.