"ASSERTION: How did we end up with a 3D transform here?!"

RESOLVED FIXED in mozilla16

Status

()

Core
Graphics
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Assigned: nrc)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla16
x86_64
Mac OS X
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 636376 [details]
testcase

###!!! ASSERTION: How did we end up with a 3D transform here?!: 'isMask2D', file gfx/layers/opengl/LayerManagerOGLProgram.cpp, line 349

This instance of this assertion was added in bug 716439.
(Reporter)

Comment 1

5 years ago
Created attachment 636378 [details]
stack trace
(Assignee)

Updated

5 years ago
Assignee: nobody → ncameron
(Assignee)

Comment 2

5 years ago
Having a transform and border radius on the body tag leads to a Thebes layer with a 3D transform and a mask layer. That is not an expected combination, so causes the assertion (indirectly because Thebes layers calculate an effective transformation differently from container layers, which is where 3D transforms are usually dealt with). I'll try to find a fix.
(Assignee)

Comment 3

5 years ago
Created attachment 636583 [details] [diff] [review]
fix
Attachment #636583 - Flags: review?(roc)
Attachment #636583 - Flags: review?(roc) → review+
(Assignee)

Comment 4

5 years ago
Created attachment 636585 [details] [diff] [review]
test
Attachment #636585 - Flags: review?(roc)
(Assignee)

Comment 5

5 years ago
Created attachment 636586 [details] [diff] [review]
test
Attachment #636585 - Attachment is obsolete: true
Attachment #636585 - Flags: review?(roc)
Attachment #636586 - Flags: review?(roc)
Attachment #636586 - Flags: review?(roc) → review+
(Assignee)

Comment 6

5 years ago
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=1209bfaff4b9
(Assignee)

Comment 7

5 years ago
Comment on attachment 636583 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 716439
User impact if declined: possible incorrect rendering
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): no obvious risks
String or UUID changes made by this patch: none
Attachment #636583 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 8

5 years ago
Comment on attachment 636586 [details] [diff] [review]
test

[Approval Request Comment]
test, see approval request comment above
Attachment #636586 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1766d4a0c876
https://hg.mozilla.org/mozilla-central/rev/1209bfaff4b9
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16
Attachment #636583 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #636586 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
https://tbpl.mozilla.org/?tree=Mozilla-Aurora&rev=771d99dd1dd8
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Target Milestone: mozilla16 → ---
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16

Comment 11

5 years ago
Did it land in Aurora?
(Assignee)

Comment 12

5 years ago
Yes, comment 10, I'm pretty sure it stuck.
You need to log in before you can comment on or make changes to this bug.