Closed Bug 768258 Opened 7 years ago Closed 4 years ago

Set new_sandbox to False by default in marionette python client and server

Categories

(Testing :: Marionette, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1123506

People

(Reporter: mdas, Unassigned)

Details

Attachments

(1 file)

This will match Selenium's expectations
I have a patch for this, but I'm waiting for Bug 761202's patch to land, since we'll have conflicts.
Attached patch fix v0.1Splinter Review
This changes the default behaviour and updates tests accordingly
Attachment #638851 - Flags: review?(dburns)
Comment on attachment 638851 [details] [diff] [review]
fix v0.1

Review of attachment 638851 [details] [diff] [review]:
-----------------------------------------------------------------

Argh, to mirror Selenium's behaviour, we'll need Marionette to know when a user changes the current window, even through execute_script. Right now, marionette doesn't listen for page load, and will use whatever window was last strictly refered to by the client (ie: via switch_to_frame, etc.). We'll need to have Marionette listening for page changes, or check that the window didn't change during a script call.
Attachment #638851 - Flags: review?(dburns) → review-
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123506
You need to log in before you can comment on or make changes to this bug.