Link clicks in content act randomly when opening tabs

RESOLVED DUPLICATE of bug 774352

Status

()

RESOLVED DUPLICATE of bug 774352
6 years ago
4 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In the metrofx front end, link clicks don't seem to follow the standard standard behavior of opening in the same tab the user is interacting with, for example:

The following links open a new tab:

1) links in about:home
2) search engine internal service links like "web", "images", "places" on google
3) search engine result links
4) next page search results links
5) generic link clicks that do not have a target set.

In some content cases though new tabs aren't opened. Why, I'm not sure.

We should to look at our new tab decision making in the fennec front end code and try to minimize the number of tabs opened. It's rather annoying and hard to manage the content you are viewing the way it is.
Also I'm not sure what the correct behavior is for Windows 8 searches, open a new tab? Ditto when a pinned site is clicked, currently it opens a new tab too.
(Reporter)

Updated

6 years ago
Depends on: 774352
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
No longer depends on: 774352
Resolution: --- → DUPLICATE
Duplicate of bug: 774352
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.