Fullscreen webm video has borders / alignment issue

REOPENED
Unassigned

Status

()

Core
Audio/Video: Playback
REOPENED
5 years ago
2 years ago

People

(Reporter: beta, Unassigned)

Tracking

(Blocks: 1 bug)

14 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120624 Firefox/15.0a2
Build ID: 20120624042007

Steps to reproduce:

Visited http://camendesign.com/code/video_for_everybody/test.html on a Galaxy Note with the latest Firefox release.

Long pressed video for fullscreen, it plays the webm file.
I did however notice that the video isn’t fully covering the screen, the right and bottom has black borders of around ~15 pixels.

Funnily, when I pause the video using the onscreen controls, it resizes to match full screen. Pressing play again it returns back to the smaller size.
Can provide photos if needed.
The resizing between play/pause sounds like bug 737021. Fixing that may take care of this issue.
Depends on: 737021
Margins are added to the video in order to preserve its aspect ratio when scaling.

Ho
(Sorry, I bumped the "save changes" button before finished typing my previous comment)

...However you are correct that the video changes size when paused in fullscreen mode, and I also noticed that you can't resume playback of the video while in fullscreen mode.
(Reporter)

Comment 4

5 years ago
(In reply to Chris Pearce (:cpearce) from comment #3)
> ...However you are correct that the video changes size when paused in
> fullscreen mode, and I also noticed that you can't resume playback of the
> video while in fullscreen mode.

You have to press the pause button, which is a bit awkward yeah.
OS: Linux → Android
Hardware: x86_64 → ARM
Confirmed:
1. goto http://camendesign.com/code/video_for_everybody/test.html
2. play the video in full screen
3. hit pause
4. pan and/or switch orientations

Expected: Full screen webm video fits the screen/has no graphic rendering
Actual: you only see part of the video in landscape; you can also make it see double in portrait... panning causes yellow lines to appear at the top/bottom of the screen.

Note:
1. Nightly 7/2/2012; Nexus S, Gingerbread
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

5 years ago
It looks like Bug 737021 fixed this in the latest Firefox Beta (15)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Created attachment 650102 [details]
screenshot

When I switch to full screen a html5 video on JB, I can see 2 borders on the left side and on the bottom of the screen (sometimes it's on the top of the screen). The borders might be not so visible in the pic, but there are annoying and so visible on the screen. Is this issue related to this bug or should I file a new one?

--
Firefox 17.0a1 (2012-08-08)
Device: Galaxy Nexus
OS: Android 4.1.1
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

5 years ago
The white pixel border? What’s the URL to the video.
This isn’t exactly the earlier issue, so I dunno.
(In reply to John Drinkwater (:beta) from comment #8)
> The white pixel border? What’s the URL to the video.
> This isn’t exactly the earlier issue, so I dunno.

I reproduced this issue on the following page:
http://www.w3schools.com/html5/tryit.asp?filename=tryhtml5_video_all (http://goo.gl/JASX2)
Duplicate of this bug: 781738
Blocks: 800673
Keywords: qawanted
Created attachment 685186 [details]
Nightly 11/26

The video border is still noticeable on the latest Nightly build.

--
Firefox 20.0a1 (2012-11-26)
Device: Galaxy S2
OS: Android 4.0.3
status-firefox20: --- → affected
Keywords: qawanted
I see the border as well on the Galaxy Nexus, but the border is ~1px on all sides of the video. The same border can be seen on desktop too if you go to that video and view it in full-screen. The border does not appear if you go the video URL directly (rather than viewing it embedded as part of the page). I'm not sure why this is happening; inspecting with firebug indicates that when it is full-screen embedded the computed CSS width/height are slightly smaller.
Component: General → Video/Audio
Product: Firefox for Android → Core
Version: Firefox 14 → 14 Branch
Just to clarify/summarize, the STR on desktop are:

1. Go to http://www.w3schools.com/html5/tryit.asp?filename=tryhtml5_video_all
2. Right-click on the video in the right pane
3. Select "full Screen"

There will be a 1-pixel wide border all around the full-screen video.
OS: Android → All
Hardware: ARM → All
Still happens on desktop, although the URL of the page has changed.
Component: Audio/Video → Audio/Video: Playback
You need to log in before you can comment on or make changes to this bug.