Last Comment Bug 768614 - WebGL compositing broken on Android (affects only Firefox 14)
: WebGL compositing broken on Android (affects only Firefox 14)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: 14 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 13:12 PDT by Daniel N.
Modified: 2012-07-18 13:32 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
fixed
fixed


Attachments
Screenshot of WebGL demo (39.28 KB, image/png)
2012-06-26 13:13 PDT, Daniel N.
no flags Details

Description Daniel N. 2012-06-26 13:12:54 PDT
http://get.webgl.org/ states that the browser supports WebGL, but the rotating cube is not displayed.

https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/demos/google/san-angeles/index.html shows a Canvas of solid color but no 3D scenery. The solid color changes as the demo runs.

It works in 16.0a1 Nightly.
Comment 1 Daniel N. 2012-06-26 13:13:51 PDT
Created attachment 636848 [details]
Screenshot of WebGL demo
Comment 2 Vladimir Vukicevic [:vlad] [:vladv] 2012-06-28 06:48:12 PDT
This sounds bad; do we have a Nexus S in toronto?
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2012-06-28 06:52:22 PDT
I have one; webgl is not broken for me, but I will update today and check.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2012-06-29 13:14:10 PDT
I can indeed reproduce this bug on my Nexus S in Firefox 14. It is fixed in Firefox 15.

Unfortunate that we didn't backport; but I guess it's too late now, and it's fixed in 15. Shall we close this as FIXED (since it's fixed in 15) or WONTFIX (since it's too late for 14)?
Comment 5 Benoit Girard (:BenWa) 2012-06-29 13:16:42 PDT
We should mark as fixed since WebGL is not broken on Nexus S. We should mark Firefox 14 as 'effected'.

Unless you rename the bug to be 'WebGL is broken on 14'
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2012-06-29 13:22:17 PDT
Alright, fixed.
Comment 7 Benoit Jacob [:bjacob] (mostly away) 2012-07-18 13:32:29 PDT
*** Bug 775220 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.