Last Comment Bug 768654 - Device Storage - Add test that verifies the content written
: Device Storage - Add test that verifies the content written
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Doug Turner (:dougt)
:
Mentors:
Depends on:
Blocks: 761930 773798
  Show dependency treegraph
 
Reported: 2012-06-26 14:47 PDT by Doug Turner (:dougt)
Modified: 2012-07-14 10:02 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (6.16 KB, patch)
2012-06-26 14:50 PDT, Doug Turner (:dougt)
bent.mozilla: review+
Details | Diff | Review

Description Doug Turner (:dougt) 2012-06-26 14:47:10 PDT

    
Comment 1 Doug Turner (:dougt) 2012-06-26 14:50:36 PDT
Created attachment 636884 [details] [diff] [review]
patch v.1

changes to test cases only


* test_basic.html now verifies the content that was added to device storage.

* this also includes some prep for IPC in tests.  For example, devicestorage_setup now only sets prefs if we are in the main process.

* also minor clean up
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-13 21:09:09 PDT
Sorry, but your push had to be backed out due to compilation errors on all platforms.
https://hg.mozilla.org/integration/mozilla-inbound/rev/7db81ae082e7

/builds/slave/m-in-lnx/build/dom/ipc/PContent.ipdl:166: error: ctor for protocol `PDeviceStorageRequest', which is not managed by protocol `PContent'
Specification is not well typed.
Comment 4 Doug Turner (:dougt) 2012-07-13 22:38:20 PDT
bad rebase - https://hg.mozilla.org/integration/mozilla-inbound/rev/75f82fd7b2b0
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-14 10:02:22 PDT
https://hg.mozilla.org/mozilla-central/rev/75f82fd7b2b0

Note You need to log in before you can comment on or make changes to this bug.