Last Comment Bug 768688 - Disable incremental GC for Firefox 15; re-enable compartment GCs
: Disable incremental GC for Firefox 15; re-enable compartment GCs
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 15 Branch
: All All
: -- normal (vote)
: mozilla15
Assigned To: Bill McCloskey (:billm)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 15:51 PDT by Bill McCloskey (:billm)
Modified: 2012-07-18 09:15 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
patch (3.30 KB, patch)
2012-06-26 15:51 PDT, Bill McCloskey (:billm)
bugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-06-26 15:51:25 PDT
Created attachment 636911 [details] [diff] [review]
patch

Incremental GC still needs to be tuned in order not to regress things. This patch is a backout of what landed in bug 735099. It's intended for Aurora.
Comment 1 Bill McCloskey (:billm) 2012-06-26 16:00:28 PDT
Comment on attachment 636911 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 735099

User impact if declined: Worse GC performance.

Testing completed (on m-c, etc.): Patch landed at the very end of FF15 cycle, so this configuration was tested on nightly.

Risk to taking this patch (and alternatives if risky): Just a backout, so should be low.

String or UUID changes made by this patch: None
Comment 2 Alex Keybl [:akeybl] 2012-06-27 15:43:23 PDT
Comment on attachment 636911 [details] [diff] [review]
patch

[Triage Comment]
Approving for Aurora 15. Please make sure to mark bug 641025 as disabled once backed out.
Comment 3 Bill McCloskey (:billm) 2012-07-02 10:56:28 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/3aad0136aada
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-18 09:15:54 PDT
[Triage Comment]
Updating status flags since this is landed on Firefox 15.

Note You need to log in before you can comment on or make changes to this bug.